Like Tree14Likes

Both my bilge blowers melted

Reply
Old 08-12-2016, 10:25 AM
  #21
Registered
 
Join Date: Sep 2013
Location: Southeast Michigan
My Boats: Progression 24XL O/B
Posts: 1,632
Default

Quote:
Originally Posted by Cole2534 View Post
Dyson? I was thinking replace them with some 22 year old skanks, it being a Fountain and all.
If you can afford the additional maintenance (Boone's Farm, Aquanet, penicillin), then by all means, go for it!
Speedracer29 is offline  
Reply With Quote
Old 08-12-2016, 10:56 AM
  #22
Registered
 
Join Date: Oct 2013
Location: rock Island wa
My Boats: 1995 fountain 24cs 1988 glasstroncarlson 16
Posts: 1,962
Default

Quote:
Originally Posted by Cole2534 View Post
Finally got back to the lake to replace them, here is one that I pulled out.

Yikes, how long had they been running to get so hot?
buck35 is online now  
Reply With Quote
Old 08-12-2016, 11:09 AM
  #23
Registered
Thread Starter
Trade Score: (1)
 
Join Date: Jun 2012
Location: OK CIty, OK
My Boats: 97 Fountain 24CS
Posts: 1,444
Default

No way to know exactly but it couldnt have been very long because the battery switch is off if Im not in the immediate vicinity of the boat.

Voltage test showed 13.9v off and 12.9 running on both sides.
Cole2534 is offline  
Reply With Quote
Old 08-13-2016, 08:41 AM
  #24
Registered
 
Join Date: Apr 2013
Location: Groton, CT.
My Boats: 04 35 lightning, 85 10 Meter Fountain, 14' Smokercraft, STX 15F
Posts: 181
Default

That's exactly what mine looked like. I really think the attwood blower is just cheap crap that ain't up to the task! Jmo, I know you are searching for a cause elsewhere . Went thru this on my 10 meter and the blowers were only a couple seasons old. Buy a jabsco unit and never look back .
flatlanderbill is offline  
Reply With Quote
Old 08-13-2016, 05:58 PM
  #25
Registered
Thread Starter
Trade Score: (1)
 
Join Date: Jun 2012
Location: OK CIty, OK
My Boats: 97 Fountain 24CS
Posts: 1,444
Default

Dang, already bought replacement Attwoods. It's moderately calming to know that I'm not the only this has happened to, but still now acceptable.

I have some more documentation I'll prepping into an report I'll send to their tech guys. I do accodent investigations and reports at work, time to use them skillz.
Cole2534 is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:37 AM.


Copyright 2011 OffShoreOnly. All rights reserved.