Like Tree4Likes

525 EFI - VIRGIN hours

Reply
Old 11-21-2017, 01:01 PM
  #1
Registered
Thread Starter
 
On Time's Avatar
 
Join Date: Nov 2004
Location: Houston
My Boats: 2005 42 Fountain, 1998 Marlago 35 FS, 2007 Sea Ray 230 Fission
Posts: 3,479
Default 525 EFI - VIRGIN hours

Time for an update on this! Let us 525 owners learn from each other. We've all heard the recommendations for top end rebuild at 200-250 hrs. I want to know how many VIRGIN hours you got before your factory engine failed or you rebuilt "to be safe". If no repairs yet post your hours. If engine failed include what happened. Include your oil type if you want. Happy reading!

I have a 42 Fountain with 355 hrs no problems whatsoever. Only use Mercruiser semi-syn 25W-40.
On Time is offline  
Reply With Quote
Old 11-21-2017, 01:21 PM
  #2
Registered
 
Join Date: May 2009
Posts: 232
Default

I don't have anything to contribute except this is a great idea to gather some real world data.
soonenough is offline  
Reply With Quote
Old 11-21-2017, 01:25 PM
  #3
VIP Member
VIP Member
Trade Score: (1)
 
Marginmn's Avatar
 
Join Date: Dec 2001
Location: Indianapolis, Lake Cumberland
My Boats: 38 Donzi ZRC, 29 Advantage XFlight
Posts: 3,473
Default

A 2007 Model had about 225 hrs and I heard tapping. Took it to Eddie Young and good thing I did. Eddie found that Needle bearings from one of the rockers had let go, but we caught it before it destroyed the lower half. BTW, Eddy's the man for 525 rebuilds if you didn't already know that.
Padraig, akaboatman and DBleil89 like this.
__________________
The Beak be gone
Marginmn is offline  
Reply With Quote
Old 11-21-2017, 04:51 PM
  #4
VIP Member
VIP Member
 
VoodooRob's Avatar
 
Join Date: Jul 2011
Location: Cleveland Ohio
My Boats: 07 Fountain 38 Lightning600SCI
Posts: 1,605
Default

Previous boat 05 353 Fastech 525s / ITS. Top ends done at 320 hrs, engines were sealed never worked on when we bought with 280 hrs. No failures, just sensors going bad. Teardown revealed head gaskets were starting to seep into each other and valve springs were very weak but not broken. Rockers and headers were all ok. Rebuilt heads, replaced lifters and pushrods for durability.

Last edited by VoodooRob; 11-21-2017 at 04:53 PM.
VoodooRob is offline  
Reply With Quote
Old 11-21-2017, 05:59 PM
  #5
Platinum Member
Platinum Member
 
H20 Toie's Avatar
 
Join Date: Sep 2004
Location: Channel Islands CA
My Boats: Got nothing
Posts: 1,462
Default

400 hours on my 525s in a Formula 400SS took the heads off just in case, all good except that valve springs were way weak so probably would not have made 450 before one broke
H20 Toie is offline  
Reply With Quote
Old 11-21-2017, 07:10 PM
  #6
Registered
Trade Score: (3)
 
Join Date: Apr 2005
Location: Lees Summit ~ LOTO 10MM
My Boats: 43SC ...............Black Thunder
Posts: 2,662
Default

450 hours on 05 525s. Most 4K to 4500rpm. Oil changes and filters.
endeavor1 is offline  
Reply With Quote
Old 11-22-2017, 03:51 PM
  #7
Registered
Thread Starter
 
On Time's Avatar
 
Join Date: Nov 2004
Location: Houston
My Boats: 2005 42 Fountain, 1998 Marlago 35 FS, 2007 Sea Ray 230 Fission
Posts: 3,479
Default

Thanks everybody!
On Time is offline  
Reply With Quote
Old 11-22-2017, 07:36 PM
  #8
Registered
 
Join Date: Jun 2014
My Boats: 2004 Formula 370SS
Posts: 383
Default

630 hours on my 500efi's unopened
370ss500efi is offline  
Reply With Quote
Old 11-23-2017, 03:28 PM
  #9
Registered
 
Join Date: Nov 2017
Posts: 2
Default 04 Sonic 31ss with twin 2006 525efi XR drives

Just had motors opened up at 340 hrs. Both stock. 1 motor was still tagged, sealed. The other had been opened at some point. Valve seat pressure was really low around 100 pounds. Valve train was in tack, but showed signs of wear and lash. Full valve train replaced. Head gaskets were starting to seep between cylinder walls. Cylinders still have a cross hatch. Heads are in great shape. Changing out composite head gaskets with multi layer steel. Port matching heads to intake and exhaust. Opening up heads around exhaust valves. Ive ran Amsoil Dominator full syn in it past two seasons. Royal Purple was in them before that. No failures. Zero issues. Run er hard as she'll let me. Top 85.7 MPH at 5400 rpm. I show the .7 because its not 86mph. YET.....
Awesome2.0 is offline  
Reply With Quote
Old 11-27-2017, 08:22 AM
  #10
dcb
Platinum Member
Platinum Member
 
dcb's Avatar
 
Join Date: Aug 2007
Location: Falmouth, Va/ PGI, Fl
My Boats: 2007 35 Lightning staggered 525s
Posts: 340
Default

Quote:
Originally Posted by Awesome2.0 View Post
Just had motors opened up at 340 hrs. Both stock. 1 motor was still tagged, sealed. The other had been opened at some point. Valve seat pressure was really low around 100 pounds. Valve train was in tack, but showed signs of wear and lash. Full valve train replaced. Head gaskets were starting to seep between cylinder walls. Cylinders still have a cross hatch. Heads are in great shape. Changing out composite head gaskets with multi layer steel. Port matching heads to intake and exhaust. Opening up heads around exhaust valves. Ive ran Amsoil Dominator full syn in it past two seasons. Royal Purple was in them before that. No failures. Zero issues. Run er hard as she'll let me. Top 85.7 MPH at 5400 rpm. I show the .7 because its not 86mph. YET.....
How will you achieve the proper RA for the MLS gaskets on the engine block?
dcb is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:05 PM.


Copyright 2011 OffShoreOnly. All rights reserved.