Like Tree0Likes

Gaffrig Speedo Leaking

Reply
Old 04-22-2003, 04:36 PM
  #11
Registered
 
Join Date: Jun 2001
Location: Michigan
My Boats: It's how well you go fast
Posts: 3,345
Default

just gave me a massive headache...but still go'n cya...let me know if you more vascular or not!?LOL
audacity is offline  
Reply With Quote
Old 04-22-2003, 04:41 PM
  #12
Platinum Member
Platinum Member
Thread Starter
 
Ran-Dom 32's Avatar
 
Join Date: Sep 2002
Location: Lake St. Clair
My Boats: Fountain 42 EX Done Deal aka "Big Sexy"
Posts: 1,930
Default

Joey, I met you 2 years ago at Sinbad's during the Thunderfest, you had just gotten your AT - We were parked behind you, my brother Bruce had the Awesome Cat (Green Flames) & I had my 280 Velocity back than - do ya recall????
Ran-Dom 32 is offline  
Reply With Quote
Old 04-22-2003, 06:46 PM
  #13
Registered
 
Join Date: Jun 2001
Location: Michigan
My Boats: It's how well you go fast
Posts: 3,345
Default

hell yeah! damn canadians! we were with jodi girl! does bruce still have it??...who's baja was i upside down in at browns??? like i said it's your if ya need it!
audacity is offline  
Reply With Quote
Old 04-23-2003, 09:16 AM
  #14
Platinum Member
Platinum Member
Thread Starter
 
Ran-Dom 32's Avatar
 
Join Date: Sep 2002
Location: Lake St. Clair
My Boats: Fountain 42 EX Done Deal aka "Big Sexy"
Posts: 1,930
Default

That was a good time, my buddy with the Baja is actually getting married to Kristy -the girl he met there that weekend. Bruce still has the cat - thinks he's on his 5th bravo by now - put in a big ass blower motor- Hope to see ya around Lake St Clair this season. take care
Ran-Dom 32 is offline  
Reply With Quote
Old 04-23-2003, 09:25 AM
  #15
Registered
 
Join Date: Jun 2001
Location: Michigan
My Boats: It's how well you go fast
Posts: 3,345
Default

no problem man...let me know...come on out to a race or two!!
audacity is offline  
Reply With Quote
Old 04-23-2003, 10:50 AM
  #16
Registered
 
Join Date: Mar 2003
Posts: 54
Default

Are you sure its leaking from gauge? I thot the that but it turned out to be the water hose split on back of speedometer..They had
wrapped a wire clip too tite and split hose.. I merely cut it off and reinstalled..This on a new 288 sunsation.
bcolmsted is offline  
Reply With Quote
Old 04-23-2003, 10:01 PM
  #17
Registered
 
Join Date: Feb 2001
Location: West Michigan. USA
My Boats: boating snowmobiling
Posts: 24
Default

Tighten the ring around the lens.It worked for me.
Super V is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Velocity Vector
General Q & A
1
04-02-2008 12:48 AM
whatabout1
Do It Yourself, Boating on a Budget
6
02-05-2008 12:32 PM
1bagger
General Boating Discussion
3
05-14-2007 05:36 AM
bearpaw
General Q & A
8
01-26-2007 01:10 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:44 AM.


Copyright 2011 OffShoreOnly. All rights reserved.