Like Tree0Likes

HELP!!! Sea Strainer Question

Reply
Old 05-18-2003, 02:10 PM
  #11
Boating Fool
Guest
 
Posts: n/a
Default

Well I found part of the problem. The impeller is smoked. I cleaned out the strainer again, and pieces of impeller was in it under the screen (the pieces backflushed to the strainer).

So that answered the what, now I have to find the why.

So now the why is - how come the impeller would disintergate the first time we put the boat in the water. The impellers and pumps were "supposely" gone over and looked at last week at the dealer before we picked up the boat. The engines were also hooked up to a water hose last week to run the engines before and after an oil change. So really the boat has not been anywhere to pick something up, unless it happened at the ramp.

Who knows. I just hope the lines are not clogged. The pump and lines are in a very difficult place to get too.
 
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rangerrick63
Sonic
1
04-30-2008 06:51 PM
BajaBennett
General Q & A
7
10-27-2006 12:48 AM
Memphis
Fountain
9
06-06-2006 06:50 PM
hugetime1
General Q & A
2
07-09-2003 06:28 PM
Madmax
Baja
5
05-15-2003 04:02 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:35 PM.


Copyright 2011 OffShoreOnly. All rights reserved.