Like Tree0Likes

Keith Eickhert

Reply
Old 04-06-2004, 03:00 PM
  #1
Registered
Thread Starter
 
VelocityMark's Avatar
 
Join Date: Sep 2002
Location: Charlotte, nc.
My Boats: 1998 velocity 280
Posts: 604
Question Keith Eickhert

Does anyone know where he works now? I am not trying to start another bad thread on this subject and if it turns into that I will delete it.
I am only curious because we have a couple of his 10 quart oil pans with pick ups and they don't seem to fit up right. We called the # listed on the web site and after talking to one of there tech guys about the problem they said they would lay a pan up and see if they could see the same problem we were seeing. We called them back today and he said that he and Keith, laid a pan up and did not find a problem. "Keith" Keith who, Keith Eickhert the man said. He told us that he had nothing to do with the parts but was there everyday building motors. Is this true?
VelocityMark is offline  
Reply With Quote
Old 04-06-2004, 03:11 PM
  #2
Registered
Trade Score: (1)
 
Join Date: Feb 2003
Location: Lafayette,La
My Boats: 31 Resin bucket
Posts: 5,334
Default

yes, keith is at the location building big power again but the building is split . kepp parts is a different company. call cp performance in FL and ask for BISCUT or pm d-hlaw. they have his cell #. i have his # but i am at work if no luck pm me and i will give you the #. what exactly does not fit?? eric
Open72 is offline  
Reply With Quote
Old 04-06-2004, 03:33 PM
  #3
Registered
 
NASCAT's Avatar
 
Join Date: Aug 2003
Location: Charlotte, NC
My Boats: 2017 Nor-Tech 340
Posts: 2,684
Default

Mark,

I'm dealing w/ Dave Smith @ KEE who has been quite helpful & knowledgeable. Jo @ Pantera is friends w/ KE & might be able to assist as well! Let me know if I can be of any assistance.

Michael
NASCAT is offline  
Reply With Quote
Old 04-06-2004, 03:40 PM
  #4
Registered
Thread Starter
 
VelocityMark's Avatar
 
Join Date: Sep 2002
Location: Charlotte, nc.
My Boats: 1998 velocity 280
Posts: 604
Default

Quote:
Originally posted by open72
#. what exactly does not fit?? eric
We are using a Moroso high volume oil pump and the pick up does not line up with out bending the bracket. after doing so to make it fit we measured the distance from the pick up to the botom of the pan and its about 3/4 to 7/8 of an inch from the pan before the gasket. They say its supposed to be 1/4" to 5/16" off the bottom.

Last edited by Velocity Mark; 04-06-2004 at 03:45 PM.
VelocityMark is offline  
Reply With Quote
Old 04-06-2004, 04:41 PM
  #5
Registered
Trade Score: (1)
 
Join Date: Feb 2003
Location: Lafayette,La
My Boats: 31 Resin bucket
Posts: 5,334
Default

the 22160 hv or the 22162. bending the bracket? the square p/u that came with the kit?
Open72 is offline  
Reply With Quote
Old 04-06-2004, 05:31 PM
  #6
Registered
Thread Starter
 
VelocityMark's Avatar
 
Join Date: Sep 2002
Location: Charlotte, nc.
My Boats: 1998 velocity 280
Posts: 604
Default

Quote:
Originally posted by open72
the 22160 hv or the 22162. bending the bracket? the square p/u that came with the kit?
Not sure what the part # is but I will find out tonight. Yes the square p/u. It is the 10qt pan that is on the web site, which I can't find right now. If you are using this pan what pump are you using? We compared a Moroso and a Mieling(sp) and they both have the same problem.
VelocityMark is offline  
Reply With Quote
Old 04-06-2004, 06:34 PM
  #7
Registered
 
mikes280's Avatar
 
Join Date: Feb 2001
Location: charlotte nc.
My Boats: velocity/proline
Posts: 1,846
Default

yes we are using the 22160 pump and i have had to bend the pickup but it is still to high in the pan almost 1 inch with out a gasket will be more once it is put together if left like this i called and talked to dave he got with keith and they checked one in the shop and it fit like it is made to fit but mine or Marks does not
mikes280 is offline  
Reply With Quote
Old 04-06-2004, 09:45 PM
  #8
Registered
 
mikes280's Avatar
 
Join Date: Feb 2001
Location: charlotte nc.
My Boats: velocity/proline
Posts: 1,846
Default

ttt
mikes280 is offline  
Reply With Quote
Old 04-06-2004, 10:58 PM
  #9
Registered
Trade Score: (1)
 
Join Date: Feb 2003
Location: Lafayette,La
My Boats: 31 Resin bucket
Posts: 5,334
Default

i used the mellings m77hv with arp stud no problem. mk4 k80031400 9 qt pan. 10 qt with filter. dunno. have the same p/u. using the composite gasket that came with the kit??? what block are u using??
Open72 is offline  
Reply With Quote
Old 04-06-2004, 11:09 PM
  #10
Registered
 
mikes280's Avatar
 
Join Date: Feb 2001
Location: charlotte nc.
My Boats: velocity/proline
Posts: 1,846
Default

i am using a merlin -11 block mark 4 type did you check how close the pickup was the first time i did not check it wish i had may be part of the reason it is apart now it was pumping all the oil to the top and would loose oil preasure on a long run at 4000
mikes280 is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BajaBennett
General Q & A
3
11-29-2005 01:30 PM
BOB ONEIL
General Q & A
1
03-30-2005 10:19 AM
dean campbell
General Boating Discussion
3
02-24-2003 11:25 PM
Ted G
General Boating Discussion
4
05-22-2002 12:49 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:48 AM.


Copyright 2011 OffShoreOnly. All rights reserved.