Like Tree0Likes

Monday damage report

Reply
Old 05-24-2004, 05:08 PM
  #1
Toxic FORMULA
Platinum Member
Thread Starter
 
mopower's Avatar
 
Join Date: May 2002
Location: pitman nj
My Boats: 1989 Formula SR-1 272 t/540's
Posts: 4,238
Default Monday damage report

OK , so what did you break over the weekend. Be ready for Memorial Day?
mopower is offline  
Reply With Quote
Old 05-24-2004, 05:21 PM
  #2
Member #2 ....Jeeezz
Charter Member
 
cigarette1's Avatar
 
Join Date: Oct 2000
Location: Kicked to the curb
My Boats: Toy Boat - Toy Boat - Toy Boat
Posts: 2,345
Default Re: Monday damage report

None here
cigarette1 is offline  
Reply With Quote
Old 05-24-2004, 05:26 PM
  #3
VIP Member
VIP Member
 
lucky strike's Avatar
 
Join Date: Sep 2003
Location: Pompano Beach, Florida
My Boats: Using LS JR. TG
Posts: 8,467
Default Re: Monday damage report

Only problem was we had a loose nut behind the wheel

LS 3 @ the wheel
Attached Thumbnails
Monday damage report-img_2972.jpg  

Last edited by lucky strike; 05-24-2004 at 06:55 PM.
lucky strike is offline  
Reply With Quote
Old 05-24-2004, 05:33 PM
  #4
Registered
 
fund razor's Avatar
 
Join Date: Mar 2004
My Boats: Apache 28 Brave
Posts: 8,170
Default Re: Monday damage report

I tore a shift bellows Friday night.
It was sinking slowly, but still sinking.

Sucks when the floaty part stops working.
Glad the bilge pump was faster than the leak!

Not sure if it was going already (probably) or if that big air off the 4-5 footers on Lake Erie friday night did it. Sure was some big air.

Where's the helicopter camera when you need it?

Port engine is missing a little after that run too. I think a plug wire came loose at the dist, I was screwing with my shift assist module.
Hoping to get everything worked out by Friday.

If not I'm launching the little boat.
fund razor is offline  
Reply With Quote
Old 05-24-2004, 05:35 PM
  #5
Platinum Member
Platinum Member
Trade Score: (1)
 
offthefront's Avatar
 
Join Date: Feb 2004
Location: Northeast,Fla
My Boats: 353 with Prochargers
Posts: 4,804
Default Re: Monday damage report

Motor got HOT again ....but was a stuck thermostat .... whew !!!!!! ....
offthefront is offline  
Reply With Quote
Old 05-24-2004, 05:50 PM
  #6
Registered
 
PhantomChaos's Avatar
 
Join Date: Dec 2000
Location: Bell Canyon, CA
My Boats: Formula FASTech 382 Sunseeker Apache 45
Posts: 12,756
Default Re: Monday damage report

I might be down for a couple of weeks. I had a screw loosen up some.
PhantomChaos is offline  
Reply With Quote
Old 05-24-2004, 06:01 PM
  #7
Registered
 
45sonic's Avatar
 
Join Date: Dec 2002
Location: Northern VA
My Boats: '00 45 Sonic
Posts: 3,401
Default Re: Monday damage report

Quote:
Originally Posted by PhantomChaos
I might be down for a couple of weeks. I had a screw loosen up some.

Not even going to touch that one


Fresh water not working and the genset shuts down after about 15 minutes. Other than that Thanks to Throttle-Up for the test props. We will have to keep trying.
45sonic is offline  
Reply With Quote
Old 05-24-2004, 06:04 PM
  #8
Registered
 
Formula Outlaw's Avatar
 
Join Date: May 2003
Location: In the Mountains
My Boats: was a 89" Formula 311-SR1
Posts: 11,772
Default Re: Monday damage report

"Outlaw" should finally be ready, problem is I don't know if I will be or not. Second kidney stone surgery in two weeks this coming Friday.

This whole kidney stone ordeal started two weeks ago tomorrow night. And to say it sucks is the biggest understatement to have ever come out of my big mouth.

I have a "shunt" inside me, where things are not meant to be inside. Thank you Percodans. Lalalala Lalalalalala Lalalalala Lala
Formula Outlaw is offline  
Reply With Quote
Old 05-24-2004, 06:04 PM
  #9
Registered
 
Join Date: Jan 2001
Location: Albany NY
My Boats: 54' Searay, 31' Rinker, 12' AB Inflatible CC
Posts: 5,180
Default Re: Monday damage report

Broke nothing !!!! and I gave the boat every opportunity to do so.

Ran her HARD ON Friday and Saturadyand even for a little bit on Sunday
otis311 is offline  
Reply With Quote
Old 05-24-2004, 06:45 PM
  #10
Registered
 
blue thunder's Avatar
 
Join Date: Nov 2001
Location: Pennsylvania
My Boats: 330 Carver 30' Scarab Panther 17' ProV Lund
Posts: 3,359
Default Re: Monday damage report

Lost all oil pressure in the starboard engine while running hard. Luckily it is only a poor wiring job by me to the sender Unluckily it is on the engine which the sender is near impossible to reach Will be ready for memorial day. You heading to the Chesepeake this weekend Cal?

BT
blue thunder is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
VelocityMike
General Boating Discussion
0
10-28-2002 10:42 AM
mopower
General Boating Discussion
5
10-14-2002 12:21 PM
mopower
General Boating Discussion
11
10-09-2002 05:22 PM
mopower
General Boating Discussion
10
09-23-2002 06:08 PM
mopower
General Boating Discussion
30
09-09-2002 06:32 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:16 PM.


Copyright 2011 OffShoreOnly. All rights reserved.