Go Back  Offshoreonly.com > Technical > General Q & A
ddt not working with my mefi 4 >

ddt not working with my mefi 4

ddt not working with my mefi 4

Old 06-07-2009, 08:55 PM
  #1  
Registered
Thread Starter
 
Join Date: Feb 2009
Location: Canada
Posts: 21
Default ddt not working with my mefi 4

hey guys i borrored my local mercruiser dealers ddt machine this weeked to check codes and a few other things and it would not work for me. it read can not communicate with ecm.
the ddt had the 2.0 version software in it.
my mefi 4 came from az speed with a custom tune for my whipple blower.
anybody have any ideas why it would not work for me? is it because az spped puts a lock on it? or is the the 2.0 software not compatible?
thanks guys.
jarock is offline  
Old 06-07-2009, 09:23 PM
  #2  
Registered
 
Join Date: Mar 2009
Posts: 496
Default

Did you turn the IGN key on?
Boat Tech is offline  
Old 06-07-2009, 09:27 PM
  #3  
Registered
Thread Starter
 
Join Date: Feb 2009
Location: Canada
Posts: 21
Default

lol. that is pretty funny!
yes i did i tried everything i could think of and i kept getting the same message on the screen
jarock is offline  
Old 06-08-2009, 03:01 AM
  #4  
Registered
 
Join Date: Mar 2009
Posts: 496
Default

Originally Posted by jarock View Post
lol. that is pretty funny!
yes i did i tried everything i could think of and i kept getting the same message on the screen
Sorry I had to ask, I would hope az speed would not lock out the basic stuff to look at, They just don't want any one else messing with their stuff. Dose the engine run normal or what is wrong? A few things would do this, "one" Would be The ECM is not geting power, The read only programm inside the ECM is not sending any thing out for some reason, Or I have had the scan tool lose the readings if the wire to the tool is anywhere close to the spark plug wires while running. And try pushing in and wiggling a little all the wires at the ECM to make sure they are pluged in all the way and the data link connector where you would hook up the tool. If the 2.0 version was not right it should sill hook up and turn on it just might not give you every sensor reading But the ECM should turn and tell you what version you would need to use. Good luck with it
Boat Tech is offline  
Old 06-09-2009, 04:11 PM
  #5  
Registered
Thread Starter
 
Join Date: Feb 2009
Location: Canada
Posts: 21
Default

anybody else have some input here? just to add a little more info the mercruiser ddt powers up then asks if engine had maf sensor then asks single or dual engine then that is when i get the message cannot communicate with ecm!!!!
please help
jarock is offline  
Old 06-09-2009, 06:37 PM
  #6  
Registered
 
Join Date: Aug 2007
Location: Richmond, Mass
Posts: 83
Default

Not to bash another company. I have'nt ever heard anything good about AZSM. One nightmare after another, I'm sure there is a few more people that will agree.
pocketchange22 is offline  
Old 06-09-2009, 08:51 PM
  #7  
Registered
Thread Starter
 
Join Date: Feb 2009
Location: Canada
Posts: 21
Default

thanks for the advice! but i guess i am stuck with this ecm for now. i am from nothern canada and there is nobody within a thousand miles from here than knows anything about this sort of thing, so any other advice will help me out
thanks guys
jarock is offline  
Old 06-11-2009, 05:22 PM
  #8  
Registered
Thread Starter
 
Join Date: Feb 2009
Location: Canada
Posts: 21
Default

any more ideas????
jarock is offline  
Old 06-11-2009, 08:09 PM
  #9  
Registered
 
Join Date: Aug 2003
Location: NEW YORK
Posts: 185
Default

the reason it doesn't work is because merc never used mefi4. they went to smartcraft before it came out. volvo did use it and the software will work on your merc/azm mefi4. most commonly you can use a techmate that was updated within the last few years with the current volvo diags.
JIMG is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser