Like Tree0Likes

shift lever question

Reply
Old 07-26-2010, 02:53 PM
  #1
Registered
Thread Starter
 
Join Date: Oct 2006
Location: Cincinnati,Ohio
My Boats: 1971 Lyman Offshore 2004 Sea Ray 320 Sundancer
Posts: 70
Default shift lever question

I've got morse shifters and throttles and i keep having an issue with my port shifter slipping back toward the neutral position( an 1inch or 2) while under way. The shifter never takes the drive out of gear but it annoys the sh!t out of me. Is there an adjustment to stop it from creeping back?
bsebesy is offline  
Reply With Quote
Old 08-16-2010, 02:01 PM
  #2
Registered
 
Join Date: Jul 2010
Location: Conway, AR
My Boats: 2003 Advantage Victory 32
Posts: 779
Default

Same thing is happening with my Morse shifter, but it is the starboard throttle. Any ideas?
CrownHawg is offline  
Reply With Quote
Old 08-16-2010, 08:22 PM
  #3
Registered
 
Join Date: Dec 2009
Location: Grain Valley,Mo
My Boats: 2000 firehawk 2600
Posts: 867
Default

check detent ball behind rear cover
firehawkcat is offline  
Reply With Quote
Old 08-17-2010, 08:24 AM
  #4
Registered
 
Join Date: Jul 2010
Location: Conway, AR
My Boats: 2003 Advantage Victory 32
Posts: 779
Default

After looking at the original post, my problem is not the shifter, but the throttle. The shifters are quite stiff and I would like to ease them up a bit. Is there adjustment for the throttles and the shifter? I took the whole shifter assembly out and see that it is actually one piece. Looks like ALOT of little parts to go flying if I try to disassemble it.
CrownHawg is offline  
Reply With Quote
Old 08-17-2010, 10:48 AM
  #5
Registered
 
Join Date: Jul 2004
Location: Hobe Sound, FL
My Boats: '89 Baja, Force 320 '88 Baja, Force 370
Posts: 121
Default

Not too had to disassemble...do it on a clean bench after you remove from the boat/cables. If you have stiff throttles/shifters, you will probably need to replace the cables. These get stiff over time and there is no fix besides replacement. My buddy did this and I just got done doing it on my boat.
Rexx is offline  
Reply With Quote
Old 08-17-2010, 10:49 AM
  #6
Registered
 
Join Date: Jul 2004
Location: Hobe Sound, FL
My Boats: '89 Baja, Force 320 '88 Baja, Force 370
Posts: 121
Default

Had... Meant to say bad
Rexx is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:21 AM.


Copyright 2011 OffShoreOnly. All rights reserved.