Go Back  Offshoreonly.com > Technical > General Q & A
Weird electrical problem >

Weird electrical problem

Notices

Weird electrical problem

Old 05-23-2011, 11:19 AM
  #1  
Registered
Thread Starter
iTrader: (3)
 
Join Date: Jul 2004
Location: chicago
Posts: 11,340
Received 57 Likes on 32 Posts
Default Weird electrical problem

Have a odd problem. Turn on the cabin power switch, which powers the stereo. Noticed yesterday, a slight humming noise coming thru the speakers, even though the stereo is off. Looked further, and the amps were staying on. Only was to get them to shut off was by clipping the remote turn on wire coming from the stereo. Also, noticed with the cabin power switch turned off, the indicator light telling you the cabin power is on, was glowing very dim. Guessing a short in the stereo?
MILD THUNDER is offline  
Old 05-23-2011, 01:28 PM
  #2  
Registered
 
Join Date: Jul 2009
Location: west of chitown, il
Posts: 461
Likes: 0
Received 0 Likes on 0 Posts
Default

Unplug the wiring loom from the sterio to find out if it is an internal short. Sounds like something went bad in the head unit to me.
mr3dman is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.