Go Back  Offshoreonly.com > Technical > General Q & A
Need twin 350 Mag MPI help >

Need twin 350 Mag MPI help

Notices

Need twin 350 Mag MPI help

Old 06-11-2012, 01:20 PM
  #1  
Registered
Thread Starter
 
Join Date: Dec 2009
Location: West Monroe, LA
Posts: 50
Likes: 0
Received 0 Likes on 0 Posts
Default Need twin 350 Mag MPI help

Also posted in the Scarab section but I figured this section got way more traffic so if the Mods want to delete one please delete the other one.

2000 Scarab 29.5' twin 350 Mag Mpi's

Ok so this boat is new to me and I'm trying to get all the little things worked out on it. What temp should my dash gauges be showing, keeping in mind I have Mpi's. I just changed the thermostats and impellers because it runs 180-190 on both engines consistently even though the parts counter said the thermostats for the boat were 160's, and after changing it still runs in that range.

Also I'm have a hard start problem. Friend said it sounds like vapor locking due to the ethanol gas, said he had the same issue in a previous boat with a 305 mpi engine. Happens more so when the boat is on an incline, like when its pulled up at the beach. Fires off, stutters and dies. Once I get it going everything is fine. I'm thinking fuel pump issue, so can someone tell me where the pump is located at on this boat, and also has anyone else had a similar issue.

Thanks.
HZ900 is offline  
Old 06-11-2012, 03:28 PM
  #2  
Registered
VIP Member
 
Join Date: Jan 2007
Location: Sweet Home, North Alabama and Orange Beach
Posts: 794
Likes: 0
Received 0 Likes on 0 Posts
Default

my temps run in the 170 to 180 range depending on water temps. They must run hotter than carbed engines due to mpi. Pump should be located on the lower port side of each engine in the cool fuel box.

Do your fuel pumps sound the same?
looseconnection is offline  
Old 06-11-2012, 03:42 PM
  #3  
Registered
Thread Starter
 
Join Date: Dec 2009
Location: West Monroe, LA
Posts: 50
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by looseconnection View Post
my temps run in the 170 to 180 range depending on water temps. They must run hotter than carbed engines due to mpi. Pump should be located on the lower port side of each engine in the cool fuel box.

Do your fuel pumps sound the same?
Someone had told me they were supposed to run a little hotter, but I've had efi engine in a Mastercraft that ran 160 as well so just wanted to make sure that was norm.

Fuel pumps sound the same, I can hear them pressurize when the key turns on. What I have to do when it happens is turn the key off and on three or four times then crank. Sometimes it will stay cranked, sometimes I have to repeat that numerous times. Was just happening on the starboard motor, but this weekend it happen on both motors every time I shut them off.

Last edited by HZ900; 06-11-2012 at 04:02 PM.
HZ900 is offline  
Old 06-11-2012, 04:19 PM
  #4  
Registered
 
Join Date: Apr 2012
Location: Akron, OH
Posts: 309
Likes: 0
Received 0 Likes on 0 Posts
Default

I have the same mystery happening. Only thing is, it's happening intermittently on either engine. I have been running ethanol as well, and, perhaps it's about time I stopped. I need to find another gas station.
Shag555 is offline  
Old 06-11-2012, 04:22 PM
  #5  
Registered
 
Join Date: Apr 2012
Location: Akron, OH
Posts: 309
Likes: 0
Received 0 Likes on 0 Posts
Default

By the way, mine runs at 170 deg.

I'll bet it's the fuel! Mine and your problem is exactly the same. I have to crank away until I get enough fuel for it to run.
Shag555 is offline  
Old 06-11-2012, 05:06 PM
  #6  
Registered
Thread Starter
 
Join Date: Dec 2009
Location: West Monroe, LA
Posts: 50
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Shag555 View Post
By the way, mine runs at 170 deg.

I'll bet it's the fuel! Mine and your problem is exactly the same. I have to crank away until I get enough fuel for it to run.
My friend with the 305 solved his problem with an in line fuel pump, in addition to the regular one. Said it has to do with it pushing the vapors out the line ??? Supposed to get the details of what he did this week. I'm just trying to get some opinions before I spend the money.
HZ900 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.