Go Back  Offshoreonly.com > Technical > General Q & A
Summit Twist-tite hoes failed >

Summit Twist-tite hoes failed

Notices

Summit Twist-tite hoes failed

Old 09-12-2012, 10:24 AM
  #1  
Registered
Thread Starter
 
Join Date: Nov 2005
Location: Fredericksburg, Va
Posts: 4,555
Likes: 0
Received 2 Likes on 2 Posts
Default Summit Twist-tite hoes failed

we had talked about this a while back...tried the summit brand twist-tite #10 when I plumbed my boat, nice to work with, after about 1 year of use, but less than 20 hours, noticed oil pressure acting funny..check oil..was low...4.5 quarts !! started checking..saw oil in bilge, but so hard to see on my boat could not tell much..traced to main oil line coming off block adapter had pushed back about 1/4-3/8" and leaking badly. pushed back on and put a hose clamp on for a temp fix...talked to summit, shipping me some aeroquip hose to replace...just letting anybody out there running it to watch out...Rob
ezstriper is offline  
Old 09-12-2012, 04:00 PM
  #2  
Registered
iTrader: (1)
 
Join Date: Feb 2011
Posts: 2,640
Likes: 0
Received 4 Likes on 3 Posts
Default

You are lucky that it did not blow off altogether. I considered these as well, but decided to go with a set of braided stainless and AR fittings.
Budman II is offline  
Old 09-12-2012, 04:04 PM
  #3  
Registered
Thread Starter
 
Join Date: Nov 2005
Location: Fredericksburg, Va
Posts: 4,555
Likes: 0
Received 2 Likes on 2 Posts
Default

I know....last boat did S/S..coast guard does not like them because they can short..so was trying something else....was assured these would be fine...so far only one was a issue...
ezstriper is offline  
Old 09-12-2012, 04:38 PM
  #4  
Registered
 
Join Date: Feb 2006
Location: Tallahassee, FL
Posts: 1,717
Likes: 0
Received 18 Likes on 8 Posts
Default

I was reading that on the two barb fittings you need a clamp too... kinda takes the easy part out of the assembly though.
VetteLT193 is offline  
Old 09-12-2012, 04:45 PM
  #5  
Registered
Thread Starter
 
Join Date: Nov 2005
Location: Fredericksburg, Va
Posts: 4,555
Likes: 0
Received 2 Likes on 2 Posts
Default

they say no clamps needed....not sure if that holds up now...
ezstriper is offline  
Old 09-13-2012, 05:59 PM
  #6  
Registered
Thread Starter
 
Join Date: Nov 2005
Location: Fredericksburg, Va
Posts: 4,555
Likes: 0
Received 2 Likes on 2 Posts
Default

summit sent me aeroquip hose, changed all of it out today, put clamps on just be sure all my fittings were 3 barb...hope these work better...hose was a lot different so we'll see...
ezstriper is offline  
Old 09-13-2012, 09:34 PM
  #7  
Platinum Member
Platinum Member
iTrader: (5)
 
johnnyboatman's Avatar
 
Join Date: May 2001
Location: NO WHERE
Posts: 3,358
Likes: 0
Received 0 Likes on 0 Posts
Default

i always clamped mine also,just peace of mind.
johnnyboatman is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.