Go Back  Offshoreonly.com > Technical > General Q & A
dominator carb question >

dominator carb question

Notices

dominator carb question

Old 07-07-2013, 10:35 PM
  #21  
Platinum Member
Platinum Member
Thread Starter
iTrader: (5)
 
johnnyboatman's Avatar
 
Join Date: May 2001
Location: NO WHERE
Posts: 3,358
Likes: 0
Received 0 Likes on 0 Posts
Default

running crane ignition, screwed with the timing still falls off at idle, then other engine acts like timing is off . if I set it like the other it starts like its got a low battery, back it back off its fine at this point im going to run it. then address this over the layup period. makes me sick to spend all these hours and all this money only to look like a fool big cool ass boat that runs when it wants to.
johnnyboatman is offline  
Old 07-08-2013, 03:56 PM
  #22  
Registered
 
Join Date: Nov 2005
Location: Fredericksburg, Va
Posts: 4,554
Likes: 0
Received 2 Likes on 2 Posts
Default

tell us more on the engine ? also putting a vacume gauge on to ck it at idle will help, what dist are you running ? does your ign box have a start retard built in ? depending on the cam/heads etc, run lots of timing to get to idle in gear decently...how does it idle @ 30 deg ? what RPM does it idle at ?
ezstriper is offline  
Old 07-08-2013, 08:37 PM
  #23  
Platinum Member
Platinum Member
 
Ran-Dom 32's Avatar
 
Join Date: Sep 2002
Location: Lake St. Clair
Posts: 1,935
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by johnnyboatman
I will say this i was leary of these engines as most of you have seen me ask several questions but it was at 85mph and climbing still when it got a little loose feeling and the trim was not working correctly, and my indicators are screwed way up, but she ran better than i thought.
what did these end up making for HP ? have you gone any faster then 85 yet? what props? I have a very similar set up '98 side by side 540's 630ish HP, motors are currently out for freshening..
Ran-Dom 32 is offline  
Old 07-09-2013, 10:20 PM
  #24  
Platinum Member
Platinum Member
Thread Starter
iTrader: (5)
 
johnnyboatman's Avatar
 
Join Date: May 2001
Location: NO WHERE
Posts: 3,358
Likes: 0
Received 0 Likes on 0 Posts
Default

it ran 85 on gps against the limiter, trim was not workin correct would not trim out under power, as far as power 625hp seemed like it ran good 28p b1s need 30s i think 90 is in the future.(or a cruiser) tired of wrenching .
johnnyboatman is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.