Go Back  Offshoreonly.com > Technical > General Q & A
Power Steering Pump Issue >

Power Steering Pump Issue

Notices

Power Steering Pump Issue

Old 07-11-2013, 07:28 AM
  #11  
VIP Member
VIP Member
Thread Starter
 
35fountain's Avatar
 
Join Date: Jul 2009
Location: NY
Posts: 752
Received 39 Likes on 28 Posts
Default

Originally Posted by stlliberator
Took me two seasons to finally figure out my PS issue..turned out to be the low pressure return line..had a small pin hole leak in it, and would cause the fluid to leak out and cause problems. I would just check, or replace the line, its simple to do, esp since you said you seen fluid in the bilge sometimes..
Hi, It seems like the leak is coming from the back of the control valve, the steering assembly inside the transom. Its wet with fluid . According to Mercruisers
diagram and parts list there was a seal rebuild kit that is no longer available for the control valve. Is this a common issue for this old type steering assembly
35fountain is offline  
Old 07-11-2013, 07:35 AM
  #12  
Registered
 
Join Date: Nov 2005
Location: Fredericksburg, Va
Posts: 4,554
Likes: 0
Received 2 Likes on 2 Posts
Default

your control valve has been modded for the Hyd steering, ck with latham or whoever your system came from, they should be able to help...
ezstriper is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.