Go Back  Offshoreonly.com > Technical > General Q & A
Sea water pressure fault >

Sea water pressure fault

Like Tree3Likes

Sea water pressure fault

Reply

Old 08-12-2018, 12:30 PM
  #1
Registered
Thread Starter
 
Join Date: May 2018
Posts: 11
Default Sea water pressure fault

Iím supposed to be taking my granddaughter s on vacation next Saturday to ride in papas boat and now this.

2005 sunny 32 496 ho mag serial number OM 680290 guardian mode on starboard engine block pressure to high reads 44 psi on the hose at idle. I have never lost an impeller and have flushed more times than I can count. Boat has new Hardin stainless pump, new pressure sensor, cleaned and resealed heat exchanger and a new thermostat just cause I replaced the grommets and it was right there.

I dont run hot 160-167 what I find interesting is when I look at the scanner data KOEO i clear the faults and it still shows 44psi I checked the port engine under the same setup and it reads .02 or basically zero. Leads me to wiring or pcm issue. Iím in Houston so maybe I could bribe John in Dallas to try and get me fixed up before the trip, it really means the world to the girls. Any ideas or direction would be awesome. I donít think I could afford to own this boat without this group. Thanks in advance.
Sstevens11 is offline  
Reply With Quote
Old 08-12-2018, 12:51 PM
  #2
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 9,349
Default

44psi sounds like fuel pressure.
SB is online now  
Reply With Quote
Old 08-12-2018, 12:55 PM
  #3
BUP
Registered
iTrader: (7)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 7,989
Default

I take it you are referring about me as being John ? And I see you have read some of my posts up here. The KOEO reading is correct LESS than 1 psi to zero. The other engine --- you have an issue and will set a guardian mode for sure.

Let me know if you are in the area. Will need a 48 hour advance notice as well Just saying. Thanks

2005 year models did not have the sensor in the power steering cooler but that depends on how late of a 2005 it is. and of course you prob have Gen 2 cool fuel set up and again that depends on how late of a 2005 year model you have. late 2005 went to Gen 3 and wps sensor went in the pwr steering cooler ----- Top back of engine location

Last edited by BUP; 08-12-2018 at 12:58 PM.
BUP is offline  
Reply With Quote
Old 08-12-2018, 12:59 PM
  #4
BUP
Registered
iTrader: (7)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 7,989
Default

scan tool does not read fuel pressure for these apps nor for ECM 555 just saying for reference
SB likes this.
BUP is offline  
Reply With Quote
Old 08-12-2018, 01:00 PM
  #5
Registered
Thread Starter
 
Join Date: May 2018
Posts: 11
Default

John I read all your posts. Very helpful. Sensor is in the seawater pump and no cool fuel that I can tell. If I bring it to you on Wednesday morning I coul hang around Dallas for a day or two. I reallly want the expert on it. Tell me how to contact you and where I need to bring it. Thx.
Sstevens11 is offline  
Reply With Quote
Old 08-12-2018, 01:04 PM
  #6
BUP
Registered
iTrader: (7)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 7,989
Default

I have a lake close to me --- like almost walking distance. I am so behind these 3,5 days of heavy rain has killed me to a stand still. can make it closer to this weekend if all possible ? where is your trip ?? location closer to me or ?? I ll try to fit this in one way or another

Last edited by BUP; 08-12-2018 at 01:15 PM.
BUP is offline  
Reply With Quote
Old 08-12-2018, 01:09 PM
  #7
Registered
Thread Starter
 
Join Date: May 2018
Posts: 11
Default

We are supposed to leave for Sam Rayburn on Saturday morning as a group from Houston. If you want it sooner just give me the time and place and I will get it there. If you want it tomorrow I can do that. Thanks for all the support. So many have benefited from your expertise. Thx
Sstevens11 is offline  
Reply With Quote
Old 08-12-2018, 01:09 PM
  #8
BUP
Registered
iTrader: (7)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 7,989
Default

is your apps stock cause you should have GEN 2 cool fuel and correct the wp sensor location impeller pump backside area.
BUP is offline  
Reply With Quote
Old 08-12-2018, 01:13 PM
  #9
Registered
Thread Starter
 
Join Date: May 2018
Posts: 11
Default

As far as I know it is stock but who knows as I am not the original owner. I may me mistaken when I say no. The boat is a 2005 but I see by the serial numbers the engines were built in late 03. Hope that helps.
Sstevens11 is offline  
Reply With Quote
Old 08-12-2018, 01:15 PM
  #10
BUP
Registered
iTrader: (7)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 7,989
Default

pouring here and tomorrow the same - we will have to lake test your app as well and run the scans .

tomorrow will be a wasted day with the storms - today is the same

Ill PM you my phone call now or later or tomorrow.
BUP is offline  
Reply With Quote

OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser