Go Back  Offshoreonly.com > Technical > General Q & A
Comp ultra pros >

Comp ultra pros

Notices

Comp ultra pros

Old 06-03-2019, 07:17 PM
  #1  
Registered
Thread Starter
 
Join Date: Apr 2001
Location: seaford N.Y. long island
Posts: 335
Received 0 Likes on 0 Posts
Default Comp ultra pros

Anybody using them? Bought a set new last year but didn"t finish building engine yet. I noticed that they don"t have an oil feed going to the roller tip so I guess they rely on splash. Not sure If I like that..Any body have any problems with them Thanks for any input
TwoKs is offline  
Old 06-03-2019, 08:09 PM
  #2  
Platinum Member
Platinum Member
iTrader: (1)
 
14 apache's Avatar
 
Join Date: Apr 2005
Location: Northport N.Y.
Posts: 2,086
Received 0 Likes on 0 Posts
Default

Originally Posted by TwoKs View Post
Anybody using them? Bought a set new last year but didn"t finish building engine yet. I noticed that they don"t have an oil feed going to the roller tip so I guess they rely on splash. Not sure If I like that..Any body have any problems with them Thanks for any input
hey are they crane I can't find comp ultra pros.
14 apache is offline  
Old 06-03-2019, 08:12 PM
  #3  
Registered
 
Join Date: Jan 2018
Posts: 191
Received 0 Likes on 0 Posts
Default

Comp Cams ultra pro magnum 1620-16 & 1820-16, I assume?
Mohavvalley is offline  
Old 06-03-2019, 08:41 PM
  #4  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 10,430
Received 160 Likes on 90 Posts
Default

Most rockers use/rely on splash oiling for the tips.
SB is offline  
Old 06-03-2019, 08:43 PM
  #5  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 10,430
Received 160 Likes on 90 Posts
Default

Originally Posted by 14 apache View Post

hey are they crane I can't find comp ultra pros.
SB is offline  
Old 06-03-2019, 09:38 PM
  #6  
Registered
 
SABER28's Avatar
 
Join Date: Aug 2002
Location: jenison mi
Posts: 1,054
Received 26 Likes on 21 Posts
Default

mine work fine , only 40 hours so far. builder was impressed.
SABER28 is offline  
Old 06-03-2019, 11:25 PM
  #7  
Registered
iTrader: (1)
 
Join Date: Oct 2013
Location: SF Bay Area
Posts: 2,661
Received 24 Likes on 17 Posts
Default

Same here with about 40hours on mine with no issues so far. I just freshened up the engine and they still look and act as if never run when I put them back in. No indication of any wear whatsoever.

Last edited by Baja Rooster; 06-03-2019 at 11:27 PM.
Baja Rooster is online now  
Old 06-04-2019, 06:24 AM
  #8  
Registered
iTrader: (1)
 
Join Date: Apr 2014
Location: North Florida
Posts: 544
Received 57 Likes on 15 Posts
Default

Very good rocker. I’ve had them in 2 motors now without issue.
ph1971 is offline  
Old 06-04-2019, 06:33 AM
  #9  
Registered
Thread Starter
 
Join Date: Apr 2001
Location: seaford N.Y. long island
Posts: 335
Received 0 Likes on 0 Posts
Default

Mohavvalley, yes they are 1820-16 but look identical to the picture that SB Posted. Getting ready to run this engine up on an engine run stand with break in oil. I always used cranes aluminum gold but bought these new on line. Going to give them a try. I don't have drip rails on my valve covers so I was thinking that these might need that?
TwoKs is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser