Go Back  Offshoreonly.com > Technical > General Q & A
Mercury 522EFI MAP sensor code. replaced still code. >

Mercury 522EFI MAP sensor code. replaced still code.

Like Tree1Likes
  • 1 Post By BUP

Mercury 522EFI MAP sensor code. replaced still code.

Reply

Old 09-13-2019, 03:13 PM
  #1
VIP Member
VIP Member
Thread Starter
 
ballon78's Avatar
 
Join Date: Aug 2009
Location: Amesbury, ma
My Boat: 2003 Fountain Express 38, 2004 Donzi Claccic 18, 1996 Hustler 32, 2005 Renegade 31 CC, 1997 Fountain 31 CC, 1972 Boston Whaler 13, 2006 Fountain Lightning 525efi's
Posts: 734
Default Mercury 522EFI MAP sensor code. replaced still code.

HELP ME PLEASE!!! 525efi pro's out there!! Having a warning alarm go off on my 2006 fountain w/ 525efi's. I scaned pcm and it says code 15 which is MAP sensor circut high, somtimes i get a code 16 which is map circut low. I have swaped MAP sensor from other motor and same code appear so its not a bad MAP sensor. when i unplug it alarm goes off and thows same code too. Sensor is reading same as barametric, ket on engine off so i know its getting reading. Alarm goes off every min or so. I checked pins and conector going into PCM555 and all look good. Any ideas? Im new to the 525efi's and help would be great. Thanks in advance.
__________________
96 HUSTLER 32, Vacuumed bagged layup, composite transom Blueprinted 502EFI's Mayfair, Dry-exhaust
ballon78 is offline  
Reply With Quote
Old 09-13-2019, 05:20 PM
  #2
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
My Boat: 94 Formula 27PC, 95 232 Rinker 454
Posts: 2,236
Default

when i unplug it alarm goes off and thows same code too
Sounds like a harness problem or PCM.

I don't have a wiring diagram for your motor, hope someone else does to give you a pin out. Need to use an ohm meter and check continuity with each wire.

Do you have 5V at the connector, and move it around to see if it changes?
AllDodge is offline  
Reply With Quote
Old 09-14-2019, 06:23 PM
  #3
VIP Member
VIP Member
Thread Starter
 
ballon78's Avatar
 
Join Date: Aug 2009
Location: Amesbury, ma
My Boat: 2003 Fountain Express 38, 2004 Donzi Claccic 18, 1996 Hustler 32, 2005 Renegade 31 CC, 1997 Fountain 31 CC, 1972 Boston Whaler 13, 2006 Fountain Lightning 525efi's
Posts: 734
Default

swapped pcm. pcm was bad.
__________________
96 HUSTLER 32, Vacuumed bagged layup, composite transom Blueprinted 502EFI's Mayfair, Dry-exhaust
ballon78 is offline  
Reply With Quote
Old 09-14-2019, 07:17 PM
  #4
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
My Boat: 94 Formula 27PC, 95 232 Rinker 454
Posts: 2,236
Default

Bummer, thats expensive
AllDodge is offline  
Reply With Quote
Old 09-15-2019, 02:00 PM
  #5
Registered
iTrader: (3)
 
Join Date: Apr 2005
Location: Lees Summit ~ LOTO 10MM
My Boat: 43SC ...............Black Thunder
Posts: 2,796
Default

See if BUP can fix it. He had a thread about fixing PCMs before.
endeavor1 is offline  
Reply With Quote
Old 09-15-2019, 02:43 PM
  #6
BUP
Registered
iTrader: (8)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 9,071
Default

Originally Posted by endeavor1 View Post
See if BUP can fix it. He had a thread about fixing PCMs before.
Thanks for putting my name on this.

he has already called me Friday nite and today. There is a reason whythe PCM failed and that will be fixed per my instructions. We are all good here, Ill update this as we go here.

There is a lot to these internal repairs of all these marine 555 ecms / pcm s that the few others are not doing. Really needed to put that out there for the fact of the matter. . ..
endeavor1 likes this.
BUP is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser