Go Back  Offshoreonly.com > Technical > General Q & A
Another Seawater/Fuel pump question. >

Another Seawater/Fuel pump question.

Notices

Another Seawater/Fuel pump question.

Old 05-25-2020, 11:51 AM
  #1  
Registered
Thread Starter
 
Join Date: Apr 2016
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default Another Seawater/Fuel pump question.

Ok so I recently rebuilt my mechanical seawater/fuel pump. All new bearings, seals, gear lube etc. now I have lube leaking out of the small weep hole. Anyone know what I could have done wrong? Sorry no photos.
BYFS is offline  
Old 05-26-2020, 11:34 AM
  #2  
Registered
Thread Starter
 
Join Date: Apr 2016
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

So this is what the pump looks like. The weep hole is in the gear lube housing, just to the side of the cam for the fuel pump.
Why would it be leaking gear lube?


Last edited by BYFS; 05-26-2020 at 11:37 AM.
BYFS is offline  
Old 05-26-2020, 08:58 PM
  #3  
Registered
Thread Starter
 
Join Date: Apr 2016
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default


Anyone?
BYFS is offline  
Old 05-26-2020, 09:43 PM
  #4  
BUP
Banned
iTrader: (9)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 9,595
Likes: 0
Received 33 Likes on 28 Posts
Default

your inner seal -- in which is the oil seal was not depth set correctly or was damaged from the install or is the wrong inner oil seal installed. There is 2 seals there, the outer is the water side seal and the inner is the oil side seal. Also did you change them out to new from the rebuild ?

Also the position of the seals face is important as well. One or more of these answers I posted is your issue
BUP is offline  
The following users liked this post:
Griff (05-27-2020)
Old 05-27-2020, 02:44 AM
  #5  
Registered
Thread Starter
 
Join Date: Apr 2016
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

New rebuilds! My guess the oil seal was not set deep enough! I assume the weep hole is right in between both seals correct? Ugh!!!! Cant believe I did that.
BYFS is offline  
Old 05-27-2020, 11:41 PM
  #6  
BUP
Banned
iTrader: (9)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 9,595
Likes: 0
Received 33 Likes on 28 Posts
Default

I seen this before so in past when I rebuilt them, I would checked them out before the install to the engine side.
BUP is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.