Go Back  Offshoreonly.com > Technical > General Q & A
HELP! Outdrivie trimming up on its own >

HELP! Outdrivie trimming up on its own

Notices

HELP! Outdrivie trimming up on its own

Old 07-03-2020, 05:51 PM
  #1  
Registered
Thread Starter
 
Join Date: Nov 2017
Location: Oak Lawn IL
Posts: 118
Received 3 Likes on 1 Post
Default HELP! Outdrivie trimming up on its own

HELP! Hey everyone. Out boating today, my stbd out drive is trimming up on its own. Soon as I turn the key it starts going up until it gets to the limiter. Ended up happening mid-trip from lunch. I pulled the fuse for the throttle trim control and it still does it. Ended up disconnecting the wiring from the trailer switch and that got me back to the marina. Boat is a 292 formula fastech. Any input welcome, hope my weekend isn't shot.

Last edited by Franks292; 07-03-2020 at 05:58 PM.
Franks292 is offline  
Old 07-03-2020, 06:43 PM
  #2  
Registered
Thread Starter
 
Join Date: Nov 2017
Location: Oak Lawn IL
Posts: 118
Received 3 Likes on 1 Post
Default

Originally Posted by Franks292 View Post
HELP! Hey everyone. Out boating today, my stbd out drive is trimming up on its own. Soon as I turn the key it starts going up until it gets to the limiter. Ended up happening mid-trip from lunch. I pulled the fuse for the throttle trim control and it still does it. Ended up disconnecting the wiring from the trailer switch and that got me back to the marina. Boat is a 292 formula fastech. Any input welcome, hope my weekend isn't shot.
drive still going up on its own with trailer switch disconnected.
Franks292 is offline  
Old 07-03-2020, 07:03 PM
  #3  
Registered
iTrader: (1)
 
Join Date: Sep 2013
Location: KY
Posts: 486
Received 13 Likes on 10 Posts
Default

Might be the up solenoid on the trim pump.


Last edited by jtbooten; 07-03-2020 at 07:18 PM.
jtbooten is offline  
Old 07-03-2020, 07:13 PM
  #4  
Registered
Thread Starter
 
Join Date: Nov 2017
Location: Oak Lawn IL
Posts: 118
Received 3 Likes on 1 Post
Default

Originally Posted by jtbooten View Post
Might be solenoid on the trim pump.
found water in a relay for the trim up. Not sure how it got wet.
Franks292 is offline  
Old 07-03-2020, 07:20 PM
  #5  
Registered
iTrader: (1)
 
Join Date: Sep 2013
Location: KY
Posts: 486
Received 13 Likes on 10 Posts
Default

Glade you found the problem.
jtbooten is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser