Go Back  Offshoreonly.com > Technical > General Q & A
454 mag mpi issues at wot >

454 mag mpi issues at wot

Notices

454 mag mpi issues at wot

Old 07-31-2020, 08:08 PM
  #1  
Registered
Thread Starter
 
Join Date: Nov 2010
Posts: 60
Likes: 0
Received 4 Likes on 1 Post
Default 454 mag mpi issues at wot

I have a 454mag efi with procharger . This season it is missing and wont pull rpm past 4500 . I changed wires plugs distributor rotor fuel filter but still runs like **** past 3/4 throttle. Runs fine every where else.
any ideas ???
Plus Man is offline  
Old 08-01-2020, 07:46 PM
  #2  
Registered
 
Join Date: Jun 2011
Posts: 1,063
Received 27 Likes on 20 Posts
Default

Originally Posted by Plus Man View Post
I have a 454mag efi with procharger . This season it is missing and wont pull rpm past 4500 . I changed wires plugs distributor rotor fuel filter but still runs like **** past 3/4 throttle. Runs fine every where else.
any ideas ???
It is likely running lean. Fuel delivery issue could be the injectors, regulator etc.
Trash is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.