Go Back  Offshoreonly.com > Owners Forum > Nordic
380 K-Plates on Flame >

380 K-Plates on Flame

Like Tree1Likes

380 K-Plates on Flame

Reply

Old 09-23-2009, 08:53 AM
  #1
Registered
Thread Starter
iTrader: (4)
 
Nordicflame's Avatar
 
Join Date: Mar 2002
Location: Layton, Utah
Posts: 1,490
Default 380 K-Plates on Flame

I currently have 280 K-Planes and have ordered 380 K-Plates to switch out.
I sent a couple PMs out asking those whom I had thought made this change but have had no brotherly help.

We have a brand new Flame here in town here that has the 380s vs my 280s and when we're running 90 it is much more stable than mine. Mine tends to start rolling side to side pretty hard
He runs his tabs at just a tad below neutral when running hard. Says it actually gains speed when he brings them down to that level when running
Tres had Nordic set this boat up with props turning in and the 380s. He ran them out and saw no difference so it must be the long tabs.

I was wondering if anyone else has made this switch and what the results were. I need to get this dialed in before dropping off our 5000 foot plateu and risking bodily harm

Thanks for any input,
Dave
Nordicflame is offline  
Reply With Quote
Old 10-03-2009, 08:08 AM
  #2
Off the Radar
Platinum Member
 
Linster's Avatar
 
Join Date: May 2001
Location: Short Pump or Colonial Beach, VA
My Boat: 39 Cigarette Unlimited, 24 South Bay Tri-toon, & Seadoo GTX
Posts: 1,097
Default

Dave,

Did you get a chance to check these out? Just wondering how they did.
Linster is offline  
Reply With Quote
Old 10-03-2009, 11:33 AM
  #3
Registered
Thread Starter
iTrader: (4)
 
Nordicflame's Avatar
 
Join Date: Mar 2002
Location: Layton, Utah
Posts: 1,490
Default

Originally Posted by Linster View Post
Dave,

Did you get a chance to check these out? Just wondering how they did.
Linnie,
I machined and painted them yesterday and am installing today. Probably won't be able to try them until next weekend due to weather.
They look cool!

BTW, your phone acidentally called me twice last Friday at midnight and left me two backround noise messages. Sounds like you were having fun; it was 2 a.m. for you
Nordicflame is offline  
Reply With Quote
Old 10-05-2009, 08:04 PM
  #4
Registered
 
Advantage's Avatar
 
Join Date: Feb 2001
Location: Cottage Grove, MN
My Boat: 1999 29' Outlaw
Posts: 346
Default

Dave, curious how your Flame is running with the new power?
Advantage is offline  
Reply With Quote
Old 10-06-2009, 08:47 AM
  #5
Off the Radar
Platinum Member
 
Linster's Avatar
 
Join Date: May 2001
Location: Short Pump or Colonial Beach, VA
My Boat: 39 Cigarette Unlimited, 24 South Bay Tri-toon, & Seadoo GTX
Posts: 1,097
Default

It did it until 5 in the morning with numerous people. Sorry for the inconvenience. It was just sitting in the garage on the back of my boat. Very weird, but has not done it again. Anyway, sorry.
Linster is offline  
Reply With Quote
Old 10-06-2009, 08:55 AM
  #6
Registered
Thread Starter
iTrader: (4)
 
Nordicflame's Avatar
 
Join Date: Mar 2002
Location: Layton, Utah
Posts: 1,490
Default

Originally Posted by Linster View Post
It did it until 5 in the morning with numerous people. Sorry for the inconvenience. It was just sitting in the garage on the back of my boat. Very weird, but has not done it again. Anyway, sorry.
No worries...
Glad you were having a good time
Nordicflame is offline  
Reply With Quote
Old 10-06-2009, 09:00 AM
  #7
Registered
Thread Starter
iTrader: (4)
 
Nordicflame's Avatar
 
Join Date: Mar 2002
Location: Layton, Utah
Posts: 1,490
Default

Originally Posted by Advantage View Post
Dave, curious how your Flame is running with the new power?
Hey Advantage,
It runs up to 88-90 GPS very, very quickly and then starts getting loose and rolling side to side which is why I am swapping tab plates.

All of my testing has been at 5000 feet so I'm trying to get everything dialed in before dropping to the sea level arena where I should be able to run it up to the triple diget mark pretty easy.

Dave

Last edited by Nordicflame; 10-06-2009 at 09:02 AM.
Nordicflame is offline  
Reply With Quote
Old 10-06-2009, 10:42 AM
  #8
Registered
 
Advantage's Avatar
 
Join Date: Feb 2001
Location: Cottage Grove, MN
My Boat: 1999 29' Outlaw
Posts: 346
Default

Cool, thanks for the update. Good luck.
Advantage is offline  
Reply With Quote
Old 10-21-2009, 10:30 AM
  #9
Gold Member
Gold Member
 
Rage's Avatar
 
Join Date: Sep 2005
Location: Missouri
My Boat: 05 Nordic Rage 520ci HP3-Raylar
Posts: 1,987
Default

Originally Posted by Nordicflame View Post
Linnie,
I machined and painted them yesterday and am installing today. Probably won't be able to try them until next weekend due to weather.
They look cool!

BTW, your phone acidentally called me twice last Friday at midnight and left me two backround noise messages. Sounds like you were having fun; it was 2 a.m. for you
How did the new tabs perform?
Rage is offline  
Reply With Quote
Old 10-26-2009, 08:48 AM
  #10
Registered
Thread Starter
iTrader: (4)
 
Nordicflame's Avatar
 
Join Date: Mar 2002
Location: Layton, Utah
Posts: 1,490
Default

Originally Posted by Rage View Post
How did the new tabs perform?
Look like it will be Spring before I can try them.

Filled her with the pink stuff over the weekend
Nordicflame is offline  
Reply With Quote

OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser