Go Back  Offshoreonly.com > Owners Forum > Spectre
Sending units on 2006 30 spectre?? >

Sending units on 2006 30 spectre??

Notices

Sending units on 2006 30 spectre??

Old 10-30-2020, 02:28 PM
  #1  
Registered
Thread Starter
 
Join Date: Oct 2020
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Sending units on 2006 30 spectre??

Hello spectre people.

I've got an 06 30 spectre that's almost done getting rigged with 300r's.

I've got an issue with the fuel sending units i believe and it's been this way since I bought the boat.

Guages read correctly when full but once they get to around 3/4 tank they both go from reading to showing empty and don't read again until I fill it back up.

My questions are

Does this sound like an issue with the sending units and if so, where are those things?? I've been crawling into the boat and even had a performance shop try and find them with no luck
Lr147 is offline  
Old 11-09-2020, 01:38 PM
  #2  
Registered
 
Join Date: Feb 2010
Posts: 42
Received 7 Likes on 3 Posts
Default

There are small half round plastic covers by the outside front edge of the rear seat. Under that cover is the sending unit. Mine was an 8" WEMA sender. This was the setup on my 2006 30.

It's been a while so don't quote me, but I believe if you disconnect the sender from the gauge and then ground the gauge, it should jump to full if working correctly.

Last edited by life is good; 11-09-2020 at 02:08 PM.
life is good is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.