Go Back  Offshoreonly.com > Owners Forum > Warlock
Listing problem... >

Listing problem...

Listing problem...

Old 03-16-2002, 11:56 PM
  #1  
Registered
Thread Starter
 
RedWarlock's Avatar
 
Join Date: Mar 2002
Location: I knew I shouldn't have made that left turn in Albuquerque...
Posts: 632
Question Listing problem...

Hi there.
I've just bought an '01, 25 World Class, and I'm currently learning the boats quirks, and habits. However, when I break her down to slow and idle from a run, or if I run under 30 knots she lists hard to port. WOT and accelerating she runs straight as an arrow, and it does have k-planes. (Both are full up, so I know it isn't that...) Anyone know of, or heard of this problem? I'm confused as to what could cause this...
RedWarlock is offline  
Old 03-20-2002, 08:43 PM
  #2  
Registered
 
SteveS's Avatar
 
Join Date: Feb 2001
Location: Verona Beach, NY USA
Posts: 215
Wink

Where have you got the boat trimmed at? On my 27' F1 boat I've found if I'm not paying attention and trim it down too much I get a similar reaction. If you have any questions please feel free to call me @ 315 439-2196

Steve
F1-36 Team Warlock
SteveS is offline  
Old 03-20-2002, 11:32 PM
  #3  
Registered
Thread Starter
 
RedWarlock's Avatar
 
Join Date: Mar 2002
Location: I knew I shouldn't have made that left turn in Albuquerque...
Posts: 632
Cool

Steve,

I had it trimmed down, like every one else does , when turning and slowing down. I finally got through to Warlock, and got the lowdown on what to do for the problem. It seems Warlocks don't like the trim down when moving, even thru turns! And most people I've spoken with for advice, (and some I didn't ) have told me to trim down for those instances. Carter @ Warlock states to trim down after I slow to idle, and not at all thru turns. I've yet to try it, but he did build the boat, so I'll take his word on it!

I guess every boat is different after all!

Thanks for the advice!

Tom.

PS. How's this season looking for you guys?
RedWarlock is offline  
Old 03-21-2002, 06:29 AM
  #4  
Registered
 
SteveS's Avatar
 
Join Date: Feb 2001
Location: Verona Beach, NY USA
Posts: 215
Smile

We'll be taking the first couple races off so that we can concentrate on our business. We're planning to starting at the Cape Cod race and take it from there. Any time you have questions feel free to call.
SteveS is offline  
Old 03-21-2002, 07:32 AM
  #5  
Registered
Thread Starter
 
RedWarlock's Avatar
 
Join Date: Mar 2002
Location: I knew I shouldn't have made that left turn in Albuquerque...
Posts: 632
Thumbs up

Thanks Steve, will do!

Good luck this season! (Not that you'll need it or anything ...)

Tom
RedWarlock is offline  
Old 03-21-2002, 08:20 PM
  #6  
Charter Member #71
Charter Member
 
DanB's Avatar
 
Join Date: Oct 2000
Location: Merritt Is., FL
Posts: 918
Default

Once just for the hell of it I gave it wot with the drive tucked in to see if I could trim it up to speed. and to see how fast it would go without any up trim. It torqued over so bad I thought it was gonna dump me. I had to back off and slow to a crawl to make it go back up. Warlocks of all sizes seem to act that way. Now I start off with neutral trim and hit the up button as soon as it rolls over. Seems to like that best. BTW mine is a 27

Dan
DanB is offline  
Old 03-21-2002, 11:38 PM
  #7  
Registered
Thread Starter
 
RedWarlock's Avatar
 
Join Date: Mar 2002
Location: I knew I shouldn't have made that left turn in Albuquerque...
Posts: 632
Unhappy

I was hoping to get to try out the info I've obtained this Sat. BUT... The weather gods say cold weather on friday nite, (ie. freezing ) so therefore it's drain the engine, and pull the plugs. I will keep you guys posted as to what works as soon as I get to run her.

Thanks for the input!

Tom
RedWarlock is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dbhammer
Nor-Tech
5
06-15-2007 05:35 PM
RedWarlock
General Q & A
1
03-25-2002 09:08 AM
RedWarlock
Warlock
2
03-25-2002 08:05 AM
RedWarlock
General Q & A
11
03-20-2002 07:27 PM
car54driver
General Boating Discussion
2
02-20-2002 06:48 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Quick Reply: Listing problem...


OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser