Go Back  Offshoreonly.com > Owners Forum > Eliminator
30 Eagle Setup & Top Speed >

30 Eagle Setup & Top Speed

Notices

30 Eagle Setup & Top Speed

Old 05-25-2015, 01:33 PM
  #1  
Registered
Thread Starter
 
Join Date: Oct 2010
Location: Columbia, IL
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default 30 Eagle Setup & Top Speed

I just bought a 2000 30' Eagle twin 500 EFI, XR with nose cone lowers, 4 blade Bravo 28p props, both drives spinning out. What are you guys running the drives & tabs at? I have only had it out a couple times and anything over 70 the boat gets real loose and starts to chine walk. Boat crusise great at 50 & 60 but after that gets a little crazy. Also what kind of top speed should it be good for?
Jrocket929 is offline  
Old 05-28-2015, 11:16 PM
  #2  
Registered User
VIP Member
 
Join Date: Jul 2007
Location: Alta Loma, CA
Posts: 859
Likes: 0
Received 0 Likes on 0 Posts
Default

Needs trim tabs for sure....
shueman is offline  
Old 05-29-2015, 11:21 AM
  #3  
Registered
Thread Starter
 
Join Date: Oct 2010
Location: Columbia, IL
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by shueman View Post
Needs trim tabs for sure....
It has 280 tabs on it. Any idea where they should be set at for a more stable ride?
Jrocket929 is offline  
Old 05-31-2015, 09:40 PM
  #4  
Registered
 
Join Date: Oct 2010
Location: Melbourne, Australia
Posts: 237
Likes: 0
Received 0 Likes on 0 Posts
Default

I think these 30XPs are as rare as hens teeth. i have one but it runs a single 700 SCI with an NXT 1 drive. I also run a 28 pitch 5 blade Mercury Maximus prop.

Mine hits 80 MPH easily. Chine walking isn't an issue. I never lower the tabs. Ever. It is a stepped hull so I dont know if they improved them from 2000 to 2006 when mine was made.
Australia is offline  
Old 06-02-2015, 03:29 PM
  #5  
Registered
Thread Starter
 
Join Date: Oct 2010
Location: Columbia, IL
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default

I think you are right about the low number of these out there. 2000 has 2 steps in the hull also. I just think it it weird that a 30' boat would get this loose at 70 mph. Next time I take it out I will try running a little more tab and see what happens.
Jrocket929 is offline  
Old 06-03-2015, 01:48 PM
  #6  
EZ
Registered
VIP Member
 
Join Date: May 2005
Location: ithaca ny
Posts: 75
Likes: 0
Received 1 Like on 1 Post
Default

I have almost the same setup . 2001 300 eagle 500 efi's dart heads ,i have xz drives with nose cones .I spine unlabbed 30's at 92-94mph ,gps .She starts chine walking around 80 , drives are at 5-6 on the indicator (if they are all the same) tabs are at even with the hull (checked that with a straight edge) .I have tried changing the props and spinning them in , wasn't good lost speed, and got really loose over 80 . I love the boat and setup, the acceleration is great from 50 -80 mph. Have fun .
EZ is offline  
Old 10-27-2015, 08:51 PM
  #7  
Registered
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

Well , I got a little excited when I seen this thread......but I see everyone having same issues I am. I also have a 2000 30 eagle, twin 565 cu in., 650 hp per side. Running 32 bravos labbed from bblades. It gets hairy after 80mph, Ive seen 95, but don't hold it long, seems to wanna bow hop. Tried running tabs but no more speed. Apparently I just need to be satisfied! Really think if I could smooth it out I would see triple digits,..... but oh well. If anyone has a cure...please share... short of buying a different boat of course.
Brandon.xp30 is offline  
Old 12-27-2015, 08:08 PM
  #8  
Registered
 
HPJunkie's Avatar
 
Join Date: Oct 2001
Location: Stillman Valley Ill
Posts: 566
Likes: 0
Received 0 Likes on 0 Posts
Default

Not on que here but I did own a 25 eagle with a 598 on the test drive.....and it scared the hell out of me with uncorrectable chine walk. I put a blown 509 in it and couldnt drive thru it. (thought I could) ended up straighting up the triangle and the steps, and sharpening the transom edge to the bottom. almost completely fixed it. I could "drive it" now. At 98 mph it gyrated and almost bounced at that speed. I did try lots of things like drive spacers to increase leverage with no avail. ended up leaving it set up more for "drag" mode with lower pitch. I had 26,28,30,32. ran the 28 most of the time. tached at 6500 but was fast as hell. lost some on top ,was fun to drive. Nobody could beat that boat, even the outboards until about 90. the real ones would finally pass me. blown olds head bigblock 1300 hp on an 24htm was a loss.... I did smoke him to 93 then he was gone!! he followed back to the beach with questions. square up the bottom and prop it for driveability, use restraint and kick some ass. Not sure they are supposed to run that fast.
HPJunkie is offline  
Old 05-06-2016, 12:45 PM
  #9  
Registered
 
Join Date: Jun 2004
Location: Sun Prairie, WI
Posts: 1,064
Likes: 0
Received 2 Likes on 2 Posts
Default

I currently own a 250XP Eliminator. I've have had it for 6+ yrs. I came from a traditional Baja 210ESS. Huge difference in how you drive these two boats. When I first test drove the 250XP, I thought there was something wrong with it. Chine walking at 70 with no steering input. Only way to make it go away was to bury the nose with trim. It took a good summer to learn how to countersteer/bump steer and keep the boat on the pad and keep the boat fast with little chine. Even in the spring, taking the boat out for the first time or two a year, i'm rusty, and can get behind the boat on the top end, around 80mph.

Have you guys, that are having problems driven other stepped hulls before? My experience, you can't just drive this like a car with no steering input at 70+. Loose is fast.
cloudmaster_321 is offline  
Old 10-19-2016, 07:43 PM
  #10  
Registered
 
Join Date: May 2016
Location: N.J
Posts: 126
Received 2 Likes on 2 Posts
Default

I just picked up a 04 300xp with twins but no power,Have a set of 510's to drop in it this winter.Has bravo's with k-planes.will be happy running mid to uper 80's.I also currently own a 250XP open bow,496 mag base,boat runs 72 and handles great and is as stable as could be!
mod58 is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.