Like Tree0Likes

NEED 525efi HEADERS (2 PAIR)

Reply
Old 02-06-2006, 07:39 PM
  #11
Joe
Offshore Cowboy
Platinum Member
Thread Starter
 
Joe's Avatar
 
Join Date: Nov 2002
Location: Houston, TX
My Boats: '03 Lip-ship Gladiator - Purchased (Not from Lip-Ship) w/ worn out Merc's posted on OSO Classifieds and told to me had "Fresh Motors." Wish I would have gotten to Philly's 1 Day Sooner and bought the Gladiator he sold to Tommy!!!
Posts: 1,834
Default Re: NEED 525efi HEADERS (2 PAIR)

Quote:
Originally Posted by Joe
UPDATE:

fyi - All of my headers were sent to CMI. 3 were repaired and I was told by CMI that the 4th was unrepairable, and then basically, that I was "f'd" and was on my own to go buy another pair! Wow!!!

What sh!tty customer service from CMI and Merc, sh!tty "monopoly" by Mercruiser and yet GREAT, GREAT price and service from the person who did hook me up (who, by the way is not from CMI or Merc!!!!!). My decision is closing in on the next boat - and I guarantee you it will only have Zul's or Sterlings!

P.S. If anyone wants the "repaired" headers, PM me. Reimburse me for the repair job ($300) and my shipping costs (which CMI also didn't pay for), and I'll have CMI ship them directly to you. I'm leaving them there unless someone wants them! Seriously, I wouldn't have the heart to sell them to someone and later find out that another seam/weld let go and grenaded an engine.
P.S. On a positive note, this is the second time I've dealt with Randy Leider at CMI. Both times he's been great. Thanks, Randy!!!! Sorry CMI and Merc. have you and all of your CMI colleagues' hands tied!
Joe is offline  
Reply With Quote
Old 02-06-2006, 09:34 PM
  #12
Masher touches my
Gold Member
 
Outdrive1's Avatar
 
Join Date: Aug 2004
Location: Phoenix, Az
My Boats: DCB DCB DCB DCB DCB
Posts: 2,280
Default Re: NEED 525efi HEADERS (2 PAIR)

Quote:
Originally Posted by Joe
P.S. On a positive note, this is the second time I've dealt with Randy Leider at CMI. Both times he's been great. Thanks, Randy!!!! Sorry CMI and Merc. have you and all of your CMI colleagues' hands tied!

Come on Joe, don't tease me like that, sign me up if your offer is still good.
Outdrive1 is offline  
Reply With Quote
Old 02-06-2006, 09:58 PM
  #13
Joe
Offshore Cowboy
Platinum Member
Thread Starter
 
Joe's Avatar
 
Join Date: Nov 2002
Location: Houston, TX
My Boats: '03 Lip-ship Gladiator - Purchased (Not from Lip-Ship) w/ worn out Merc's posted on OSO Classifieds and told to me had "Fresh Motors." Wish I would have gotten to Philly's 1 Day Sooner and bought the Gladiator he sold to Tommy!!!
Posts: 1,834
Default Re: NEED 525efi HEADERS (2 PAIR)

Quote:
Originally Posted by BADKACHINA
Come on Joe, don't tease me like that, sign me up if your offer is still good.
Sorry, Solllllllllllllllllllllld!!!!!
Joe is offline  
Reply With Quote
Old 02-07-2006, 09:15 PM
  #14
Registered
 
Join Date: Jun 2003
Location: Atlanta, GA
My Boats: 2000 Campion Chase 910
Posts: 220
Default Re: NEED 525efi HEADERS (2 PAIR)

OK, am I reading here that there is a problem with the CMI sweeper headers???? Seeing I just put a set of these on late last season, is there something I need to keep and eye out for? What weld seem cracks?
Chase910 is offline  
Reply With Quote
Old 02-07-2006, 10:28 PM
  #15
Platinum Member
Platinum Member
 
ApachePete's Avatar
 
Join Date: Aug 2001
Location: Sarasota,FL & Saugatuck, MI
Posts: 1,044
Default Re: NEED 525efi HEADERS (2 PAIR)

Quote:
Originally Posted by rackster
Is this a common problem with this type of exhaust or is this boat an isolated incident?
VERY common.
ApachePete is offline  
Reply With Quote
Old 02-08-2006, 10:35 AM
  #16
Joe
Offshore Cowboy
Platinum Member
Thread Starter
 
Joe's Avatar
 
Join Date: Nov 2002
Location: Houston, TX
My Boats: '03 Lip-ship Gladiator - Purchased (Not from Lip-Ship) w/ worn out Merc's posted on OSO Classifieds and told to me had "Fresh Motors." Wish I would have gotten to Philly's 1 Day Sooner and bought the Gladiator he sold to Tommy!!!
Posts: 1,834
Default Re: NEED 525efi HEADERS (2 PAIR)

Quote:
Originally Posted by Chase910
OK, am I reading here that there is a problem with the CMI sweeper headers???? Seeing I just put a set of these on late last season, is there something I need to keep and eye out for? What weld seem cracks?
Sorry to say... I have "off-record" comments that I don't feel comfortable sharing. I will say this... If you have the "Cool Collar" Spt. Tubes you'll be in much better shape. But, I might be inclined to agree with the post right above this one.

FYI - As stated in my prior posts, I will be hard-pressed to buy another boat w/ 525's or 600's, due to this problem. CMI seems to have their hands tied w/ Merc. on these. However, in my past experiences (especially w/ Randy @ CMI), they are more than happy to work w/ "us" on any faulty header product(s).
Sorry I can't share more.

Joe
Joe is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gsmith9898
General Q & A
6
04-23-2006 07:00 AM
Joe
Cigarette
4
02-06-2006 08:41 PM
Joe
General Q & A
9
02-06-2006 07:43 PM
puder
General Boating Discussion
3
12-15-2003 01:58 AM
Joe
General Q & A
0
12-09-2003 08:43 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:30 PM.


Copyright 2011 OffShoreOnly. All rights reserved.