Go Back  Offshoreonly.com > General Discussion > General Boating Discussion
525 heat exchanger issues??? >

525 heat exchanger issues???

Notices

525 heat exchanger issues???

Old 06-26-2007, 06:49 PM
  #1  
Registered
Thread Starter
 
UNSANE's Avatar
 
Join Date: Sep 2005
Location: O-town
Posts: 1,775
Likes: 0
Received 1 Like on 1 Post
Default 525 heat exchanger issues???

Not sure if there really is a problem. Port header at idle does not flow a lot of water and of course runs hotter. Tried a simple garden hose backflush and no debris or brown stuff came out. I then put the hose on the IN side and sure enough, more water flows out of the right side than the left. I thought that strange since the IN is on the port side of the exchanger next to the OUT for the port header. Does the raw water take a 'path' through the setup that might explain this, or is there something wrong? I seem to remember my water pressure was a little on the high side last time out, but not sure of an exact number, it was kind of rough. Next time out, I will pay more attention to the gauge and check header temps after coming off plane. But like I said, I'm not sure anything is wrong.

Thoughts???? Or prior experience with this???
UNSANE is offline  
Old 06-26-2007, 10:13 PM
  #2  
OSO
Charter Member
Charter Member
 
OSO's Avatar
 
Join Date: Oct 2003
Posts: 2,732
Likes: 0
Received 1 Like on 1 Post
Default

just for fun remove the rubber jumper that connects the header to the tail pipe. See if there are restrictors. The restrictors could cause the headers to run at different temps.
OSO is offline  
Old 06-27-2007, 08:18 AM
  #3  
Registered
Thread Starter
 
UNSANE's Avatar
 
Join Date: Sep 2005
Location: O-town
Posts: 1,775
Likes: 0
Received 1 Like on 1 Post
Default

Already did that. H.E. is defintely the cause, less water flows out of port side. Just don't know if that's by design. I only had a garden hose to test it though.
UNSANE is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TRL505
Fountain
0
07-18-2007 06:47 PM
troc
General Q & A
3
07-26-2006 10:12 AM
ZP\'d
General Q & A
2
06-27-2006 12:40 PM
raynman
General Q & A
3
05-13-2006 06:23 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Quick Reply: 525 heat exchanger issues???


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.