Like Tree0Likes

575 sci acting up

Reply
Old 06-15-2008, 02:46 PM
  #1
Registered
Thread Starter
 
Join Date: Feb 2005
Posts: 7
Default 575 sci acting up

I have a low hours 575sci in my Scarab 26 and just recently it has started to cough when I throttle up, then when I return to idle it revs up and down a few times on its own and then dies. My mechanic is checking the fuel pressure but were not sure what it should be on the 575. Does anybody have any ideas as to what the problem is or what the fuel pressure is on these? Thanks for any help!!!
teidsmore is offline  
Reply With Quote
Old 06-15-2008, 02:56 PM
  #2
Registered
 
Join Date: Jul 2003
Location: miami fla.
My Boats: Avance
Posts: 1,549
Default

I believe it should be 35-38 pounds on idle.....check the pressure its extremely important on these motors or anything with a supercharger (I learned it the hard way)....I melted two pistons due to a bad pump and no fuel preesure guage....
lowblue320 is offline  
Reply With Quote
Old 06-15-2008, 08:45 PM
  #3
OSO Moderator
Charter Member
 
BillR's Avatar
 
Join Date: Oct 2000
Location: Virginia Beach, VA
My Boats: '00 Scarab Sport 302 CC
Posts: 3,580
Default

They have 28 to 30 PSI @ Idle.
Have you checked the IAC?
__________________
BillR

'00 Scarab Sport 302 CC
'02 Cigarette Top Gun TS
'02 PQ 340
'00 PQ 280
'98 Scarab 22
'97 Baja Outlaw 20
'72 Checkmate
'65 Glastron
BillR is offline  
Reply With Quote
Old 06-15-2008, 09:23 PM
  #4
Registered
 
Join Date: Jul 2001
Location: Pomona,ca
My Boats: 38' Scarab P-38
Posts: 482
Default

35-38 is way too high. Don't forget these are still TBI units. That kind on fuel pressure will hold the injectors shut. I was told 26 psi at idle w/vac disconnected. Or 28-30 psi wot under load. Mine studdeded and misfired when my fuel pressure was spiking up at 33 psi wot. Good luck and keep up posted Mike
Michael Garibay is offline  
Reply With Quote
Old 06-15-2008, 09:24 PM
  #5
Registered
 
JCPERF's Avatar
 
Join Date: Jul 2004
Location: Long Island,New York
My Boats: 10 foot Kayak
Posts: 8,908
Default

I say IAC
JCPERF is offline  
Reply With Quote
Old 06-15-2008, 11:21 PM
  #6
Registered
 
Join Date: Jul 2003
Location: miami fla.
My Boats: Avance
Posts: 1,549
Default

Quote:
Originally Posted by BillR View Post
They have 28 to 30 PSI @ Idle.
Have you checked the IAC?
you could be right, I have to check with Lupe from Tnt again, him and my builder Steve from Progressive racing engines were in contact and maybe I heard wrong...........
lowblue320 is offline  
Reply With Quote
Old 06-16-2008, 08:30 PM
  #7
Registered
 
Join Date: Jul 2003
Location: miami fla.
My Boats: Avance
Posts: 1,549
Default

Quote:
Originally Posted by BillR View Post
They have 28 to 30 PSI @ Idle.
Have you checked the IAC?
checked today with my builder and yes 28-30 is correct......
lowblue320 is offline  
Reply With Quote
Old 06-17-2008, 07:32 AM
  #8
OSO Moderator
Charter Member
 
BillR's Avatar
 
Join Date: Oct 2000
Location: Virginia Beach, VA
My Boats: '00 Scarab Sport 302 CC
Posts: 3,580
Default

It is easy to put a mechanical gauge in line to measure fuel pressure.
I'll bet it is the IAC. Set it @ 14-16 and it should run great.

Also doubt this is the cause - but DO check the timing as well.
__________________
BillR

'00 Scarab Sport 302 CC
'02 Cigarette Top Gun TS
'02 PQ 340
'00 PQ 280
'98 Scarab 22
'97 Baja Outlaw 20
'72 Checkmate
'65 Glastron
BillR is offline  
Reply With Quote
Old 07-14-2008, 10:40 PM
  #9
Platinum Member
Platinum Member
 
Join Date: Jul 2006
Posts: 22
Default 575sci question

I'm having the same symptoms with my 575 in a 27 baja. Did you figure out what the problem was? I've had a fuel pressure gauge on my dash since I installed the used motor. It always reads 28 at idle and 26-28 at full throttle. My fuel pressure never changes when this problem occurs. I pulled the IAC motors and checked them with a ohm meter like the 575 service manual states. They both check out perfect. Any help would be appreciated. I just ordered a MAP sensor because it did not check out on both readings. One was fine 1.4Kohms, the other .50 ohms was reading 4.5mohms. I have a mercury scan tool and it shows no codes.

Thanks,

Dale
Dminnick is offline  
Reply With Quote
Old 07-15-2008, 08:01 AM
  #10
OSO Moderator
Charter Member
 
BillR's Avatar
 
Join Date: Oct 2000
Location: Virginia Beach, VA
My Boats: '00 Scarab Sport 302 CC
Posts: 3,580
Default

What is the IAC value @ idle from the scan tool?
Should be 15 or REAL close.
__________________
BillR

'00 Scarab Sport 302 CC
'02 Cigarette Top Gun TS
'02 PQ 340
'00 PQ 280
'98 Scarab 22
'97 Baja Outlaw 20
'72 Checkmate
'65 Glastron
BillR is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lakeman2
General Q & A
7
09-17-2008 07:24 PM
dennis r
General Q & A
1
07-19-2007 09:34 PM
jharran
General Q & A
3
05-21-2007 10:15 AM
SuperiorOKC
General Boating Discussion
1
01-12-2007 04:09 PM
Quiet Storm
General Q & A
8
02-02-2003 12:02 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:36 AM.


Copyright 2011 OffShoreOnly. All rights reserved.