Like Tree0Likes

Are my speeds off???

Reply
Old 09-13-2008, 09:37 AM
  #11
Registered
VIP Member
 
Join Date: Jan 2004
Location: Boca Raton, FL
My Boats: None
Posts: 3,682
Default

Quote:
Originally Posted by Carder View Post
sounds like you have a deep X dimension... the 4 blade may be holding you in the water.
Consider trying a Mirage plus, 1 size bigger than your current 4 blade. If the X is deep, the 3 blades are better.
Carder
BINGO!!
Edward R. Cozzi is offline  
Reply With Quote
Old 09-13-2008, 09:51 AM
  #12
Registered
 
Join Date: Jul 2004
Posts: 14
Default

We had a 1997 24 convincer 385 h.p. 454 mag. The boat ran 69.5 gps with a 23 pitch mirage 3 blade. I had a 24 pitch 4 blade bravo one labbed and the boat still ran a solid 69 mph. Looking at the photo it appears that you need to get some more bow lift. These boats run fastrest with a lot of trim balanced on the pad. Hope this helps.
FOUNTAINWOMAN32 is offline  
Reply With Quote
Old 09-13-2008, 10:42 AM
  #13
Registered
 
Join Date: May 2005
Location: LOTO Performance Boat Center
My Boats: Fixing yours
Posts: 3,897
Default

3 blades or hydros are no good on this hull, been down that road before. You need a labbed bravo with added cup. Looking at the pic of your boat running the hull is VERY wet!
Magic Medicine is offline  
Reply With Quote
Old 09-15-2008, 10:46 AM
  #14
Registered
Thread Starter
 
noyzee's Avatar
 
Join Date: Jul 2008
Posts: 1,544
Default

yea, it seems like it runs to much in the water, like its dragging it down.
i trim it up untill she starts to over rev. it runs faster and faster as i trim, then bang, rev limiter. seems like i need to mess with the prop. would a lab fin from Merc work well?
noyzee is offline  
Reply With Quote
Old 09-15-2008, 07:50 PM
  #15
Registered
 
Join Date: Jul 2007
Location: San Diego
My Boats: Advantage 28ft Sport Cat w/ pair of 8's
Posts: 989
Default

Fromthe photo, it doesn't look as if the boat is even getting up on the pad. It would be worth calling BBlades and showing them this thread with the photo. Im sure it's something they can help with.



Darrell.
DMOORE is offline  
Reply With Quote
Old 09-15-2008, 09:04 PM
  #16
Registered
 
Join Date: May 2005
Location: LOTO Performance Boat Center
My Boats: Fixing yours
Posts: 3,897
Default

Quote:
Originally Posted by noyzee View Post
yea, it seems like it runs to much in the water, like its dragging it down.
i trim it up untill she starts to over rev. it runs faster and faster as i trim, then bang, rev limiter. seems like i need to mess with the prop. would a lab fin from Merc work well?
If you are bangging the limiter with that kind of ease you definately need a bigger prop. You also need to add cup to get more bow lift and get the boat back on the pad wear it needs to run. BBlades is your answer.
Magic Medicine is offline  
Reply With Quote
Old 09-16-2008, 01:05 AM
  #17
Platinum Member
Platinum Member
Trade Score: (1)
 
articfriends's Avatar
 
Join Date: Jun 2004
Location: Frankenmuth
My Boats: EX 99 MPH 272 Baja owner, 1999 Scarab 33 AVS NOW
Posts: 6,072
Default

Do you have extra bs in the cabin? Keep in mind if you run with a extra 100-200 lbs in cabin boat will run wet. My buddy "old Navy" on here has a checkmate,it ALWAYS runs wet and heavy because his woman brings enough stuff for 2 weeks (suitcases,cans of baked beans,winter clothes,phone books for most mi area codes,arts and crafts,lawn furniture-YOU NAME IT) in the cabin for a after noon ride,Smitty
articfriends is offline  
Reply With Quote
Old 09-16-2008, 08:59 AM
  #18
Registered
Thread Starter
 
noyzee's Avatar
 
Join Date: Jul 2008
Posts: 1,544
Default

here is a couple more.

as for stuff in the cabin, yes, sometimes there is a **** load, but in these pics, and on my top speed runs theres slim to none. besides the 15" sub woofer in the very bow, but the boat ran the same befor and after that.





noyzee is offline  
Reply With Quote
Old 09-16-2008, 09:01 AM
  #19
Registered
Thread Starter
 
noyzee's Avatar
 
Join Date: Jul 2008
Posts: 1,544
Default
















also, i dont know if these photos are all out, it might not be trimmed up 100% im sure she isnt exactly where she rides, but its pretty close
noyzee is offline  
Reply With Quote
Old 09-16-2008, 11:29 AM
  #20
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,752
Default

You're running way too wet. At WOT and trimmed up, you should be running with only the last 5 feet of boat touching the water.

Check for some hook in the last 3 feet of the hull.
Do you have tabs????? How are they in relation to hull when all the way up????
Griff is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sacaja
Cigarette
5
03-07-2008 09:33 PM
Single With Twins
Fountain
6
12-26-2006 11:38 AM
Courtholl
Pantera
7
11-01-2006 02:11 PM
TeamSaris
Baja
3
03-21-2006 11:12 PM
JBOUTLAW25
Baja
5
07-12-2005 08:55 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:27 AM.


Copyright 2011 OffShoreOnly. All rights reserved.