Like Tree0Likes

MSD Ignitions

Reply
Old 05-21-2002, 11:30 PM
  #1
Registered
Thread Starter
 
Wardey's Avatar
 
Join Date: Nov 2001
Location: Palm Harbor, FL
My Boats: 2005 Extreme 29
Posts: 3,959
Default MSD Ignitions

Anyone ever have bad luck with MSD Ignitions? Especially the distribs?
Wardey is offline  
Reply With Quote
Old 05-21-2002, 11:59 PM
  #2
Registered
 
Turbojack's Avatar
 
Join Date: Sep 2001
Location: Houston, TX, USA
My Boats: 2003 Eliminator 30' Daytona
Posts: 2,285
Default

Had a bad MSD digital 6 box. Been fighting that problem for a long time. Don't know if that was the problem with motor before when I used it. Swaped to the old MSD6 box & motor came alive. I called MSD & asked it they could fix box but they said was not repairable & tech guy said he did not think it was bad, but I could send it to them for testing. This was after I told him only swap was box & that make motor wake up. Was at party this last weekend & tellling my story. Talked to two other people that said they had problems with the digital boxes. E

As far as distributer goes have had the same one for 10 years now & still working. Keep having to clean the inside up for it rusting so bad
Turbojack is offline  
Reply With Quote
Old 05-22-2002, 10:32 AM
  #3
Were doomed!
Charter Member
Trade Score: (1)
 
Wally's Avatar
 
Join Date: Oct 2000
Location: Chicago, IL
My Boats: Chris Craft Stinger 222
Posts: 5,529
Default

yup, corrosion is a big problem for me too!
And i had a 6M box go bad on me as well! Luckly it was still under their warranty so i had my speedshop guy just swap it out with one off the shelf and send it back to them for no down time!
__________________
-Wally

Money can't buy happiness, but it can buy horsepower. And I've never seen a sad person hauling a$$!
Wally is offline  
Reply With Quote
Old 05-22-2002, 11:18 AM
  #4
turbo2256
Guest
 
Posts: n/a
Default

I have used several MSD set ups on cars with little trouble. For the last 3 seasons I have run a Jacob s with no problems on my boat. It did every thing it promised.
 
Reply With Quote
Old 05-22-2002, 11:23 AM
  #5
Charter Member
Charter Member
 
Katdrvr's Avatar
 
Join Date: Feb 2001
Location: Gretna, Ne
My Boats: 32 Skater, '84' Chris Cat '82' Excalbur Hawk 40 '93' Scarab Sprint
Posts: 264
Default

I have had the corrosion problem with the MSD distributors. Never had any problem with the MSD 6M boxes I have used though. I also have a Jacobs set up in one of my boats and I think does much better job than the MSD. The Jacobs makes my old carb'd 350 start and run like it has fuel injection.

mike
Katdrvr is offline  
Reply With Quote
Old 05-22-2002, 11:40 AM
  #6
Registered
Thread Starter
 
Wardey's Avatar
 
Join Date: Nov 2001
Location: Palm Harbor, FL
My Boats: 2005 Extreme 29
Posts: 3,959
Default

Thanks Guys, I too have had great luck with them in the auto world but am hearing horor stories in the marine world. Corrosion probs in the distribs to box's shutting down. Thanks for the imput ! Dave Warden
Wardey is offline  
Reply With Quote
Old 05-22-2002, 12:41 PM
  #7
Registered
 
Tonto's Avatar
 
Join Date: Oct 2000
Posts: 1,782
Default

Just put ALL new Mercruiser ignition on the 41, if that tells you my opinion. Took off MSD box, rev-limiter,dist, and old merc module.
Robert
Tonto is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pkspx
General Q & A
61
08-20-2015 10:06 AM
302Sport
General Boating Discussion
0
06-02-2008 10:09 AM
FWK
General Q & A
9
08-14-2003 08:20 PM
BAD-HABIT
General Q & A
17
02-09-2003 08:34 PM
THRILLSEEKER
General Q & A
5
07-08-2002 12:27 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:42 PM.


Copyright 2011 OffShoreOnly. All rights reserved.