Like Tree0Likes

KE Valve Covers CURE????

Reply
Old 07-18-2011, 07:21 PM
  #31
Registered
Thread Starter
 
nitrousnolan's Avatar
 
Join Date: Jun 2005
Location: NY
My Boats: Just A Rider
Posts: 716
Default

Well I've been working with Scott and Jeff at KE, both have been very helpfull and OVERNIGHTED me a New set of covers and bases for each motor, I put them on and no more leak. I shared the pics with KE that Kid Nova lead me to of the bases he modified. So all is well now and hopefully no more oil in the bilge.
nitrousnolan is offline  
Reply With Quote
Old 07-19-2011, 06:53 AM
  #32
Registered
Trade Score: (4)
 
Join Date: Oct 2002
Location: Bowling Green, Kentucky
My Boats: DCB F-32
Posts: 1,860
Default

What was the cure. Mine are creating a mess.
SkiDoc is offline  
Reply With Quote
Old 07-19-2011, 09:05 AM
  #33
Platinum Member
Platinum Member
 
Join Date: Sep 2006
Location: brewster ma
My Boats: 37 outerlimits stiletto
Posts: 429
Default

Quote:
Originally Posted by nitrousnolan View Post
Well I've been working with Scott and Jeff at KE, both have been very helpfull and OVERNIGHTED me a New set of covers and bases for each motor, I put them on and no more leak. I shared the pics with KE that Kid Nova lead me to of the bases he modified. So all is well now and hopefully no more oil in the bilge.
Quote:
Originally Posted by SkiDoc View Post
What was the cure. Mine are creating a mess.
If you look at post 2 and what kidnova posted,,it would be my friend bill(sutphen30) fix.he cut mine and all the valve cover spacers that go thru their shop..Now it looks like KE is taking the fix and incorporating it.
shaun harrington is offline  
Reply With Quote
Old 07-19-2011, 02:05 PM
  #34
Registered
 
Join Date: Jan 2004
Location: Tennessee
Posts: 4,452
Default

They have new bases with a rubber gasket that sits at the bottom of the base, in addition to the o-ring. When the cover is tightened down, it presses into the gasket so no oil will get past it.
Give me a shout Eric and we can get yours swapped out.
Eddie
Young Performance is offline  
Reply With Quote
Old 07-19-2011, 03:12 PM
  #35
Registered
 
Join Date: Jun 2006
Location: ILL
My Boats: 06 Eliminator Daytona 27'
Posts: 739
Default

WOW this is B.S.!!! Sorry man......... But glad you got it but what a long road for such a easy part!!!!

Last edited by skydog; 07-19-2011 at 03:16 PM.
skydog is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:52 PM.


Copyright 2011 OffShoreOnly. All rights reserved.