Like Tree0Likes

It'Monday,Who brke what

Reply
Old 08-19-2002, 08:38 PM
  #11
Registered
Platinum Member
 
Join Date: Sep 2001
Location: Kingsville----lake erie
My Boats: 97 41' Saber --Ancestral Spirit
Posts: 1,328
Default

Besides some loose screws, and the cuddy door, my new sony stereo totally astounded us this weekend! Once the shelf in which it is normally housed, came crashing down after a 6 footer just dropped us, the crazy thing kept playing a cd hanging by its own wiring harness Ithought for sure it was playing off memory---but no definitely the CD
Definitely a testimonial for the new sony mex deck. Now to tighten everything back up and make a new shelf!
delsol is offline  
Reply With Quote
Old 08-19-2002, 09:10 PM
  #12
Registered
Trade Score: (2)
 
Join Date: Aug 2001
Location: OPKS & LOTO
My Boats: 1999 Cobalt 293 and 1974 Cigarette 20
Posts: 819
Default

Installed a new MSD coil then went to test on the hose a found no water coming out the exhaust. Very bad thing. Shut every thing down and discoverd that the impeller was completly shot. I mean not a single vane still in place. Come to find out some of the pieces were in the bilge next to the pump. Previous owner or shop opened the housing pulled out the loose pieces and slapped it back together!!! WTF!!! I'm just glad I caught it when I did. Hopefully no engine damage (trying to type with fingers crossed)

Tracking down parts now. If anybody can help, chime in or PM me.
Thanks,
Travis
Holy Smokes is offline  
Reply With Quote
Old 08-19-2002, 09:13 PM
  #13
ronrally
Guest
 
Posts: n/a
Default My broken heart...

You guys are pretty die-hard. I love it when people call it like it is. "Ok it's monday, who broke what?" That's awsome. I guess we need to accept a fact that boats are just expensive holes in the water. And you know, even I'm not immuned in my 20 foot fiberglass bondo-bucket, for every time one of you guys blow by me at 100 mph, it's my heart that breaks.

Ronny
 
Reply With Quote
Old 08-19-2002, 09:38 PM
  #14
Banned
 
cuda's Avatar
 
Join Date: Sep 2001
Location: Deland, Florida
Posts: 25,191
Default

I am happy to report that the worst thing for me this weekend was two dead batteries at the boat launch. I was blaming it on the automatic bilge, because the angle I keep the boat at the house doesn't let a small part of the bilge drain, and of course that is where the float switch is located. I pulled the battery out of the truck and replaced one in the boat and went on our way. After we got home and were cleaning the boat, I discovered that my swabbie (Debbie) had accidently turned on the cockpit lights when she was wiping down the dash last week. She didn't realize it was a three way switch, and she had turned it to the down (off) position.


Picture of the swabbie at the helm yesterday.
Attached Thumbnails
It'Monday,Who brke what-capt-debbie.jpg  
cuda is offline  
Reply With Quote
Old 08-19-2002, 10:06 PM
  #15
Toxic FORMULA
Platinum Member
Thread Starter
 
mopower's Avatar
 
Join Date: May 2002
Location: pitman nj
My Boats: 1989 Formula SR-1 272 t/540's
Posts: 4,238
Default

That looks it a Formula cuda
mopower is offline  
Reply With Quote
Old 08-19-2002, 10:38 PM
  #16
Donzi33ZX
Gold Member
 
BryanTuvell's Avatar
 
Join Date: Mar 2001
Location: Suffolk, VA
My Boats: 2003 Donzi 33ZX
Posts: 731
Default

I have heard so many broke stories lately I nursed mine at 4200 to 4500 anddonly very short bursts of WOT...
Waiting on my turn!

Oh and for once my stereo was still mounted when I got home, need a stronger L bracket in the back, this weeks project!
Bryan
BryanTuvell is offline  
Reply With Quote
Old 08-19-2002, 11:02 PM
  #17
Bo Knows
Guest
 
Posts: n/a
Default

The screws that hold the hatch ram to the transom pulled out, one of my step pad slats got broken, I have no idea how, the screws that hold my refridgerator fell out along with the fridge. I consider this a good weekend ! This is why I trailer my boat home, I need the week to get it back into shape and cleaned up for this weekend.

Bo
 
Reply With Quote
Old 08-19-2002, 11:21 PM
  #18
Registered
 
thunderdan's Avatar
 
Join Date: Oct 2000
Location: medford, nj usa
My Boats: 37 Active Thunder
Posts: 2,185
Default

This weekend was a trouble free one for me. Had four impellors **** the bed three weekends ago, then had some ignition switch trouble the next week, then the following week the ignition switch failed completed and had to replace the switch, then this past weekend.....no problems. Got to love boating.....
thunderdan is offline  
Reply With Quote
Old 08-19-2002, 11:22 PM
  #19
Registered
 
yzbert's Avatar
 
Join Date: Apr 2001
Location: Petoskey, MI
My Boats: 2003 37 Active Thunder
Posts: 1,190
Default

One bottle of amaretto sp? and one bottle of vanilla stoli. very rough weekend. cabin has a pleasent smell though.
yzbert is offline  
Reply With Quote
Old 08-20-2002, 12:09 AM
  #20
Registered
 
Back4More's Avatar
 
Join Date: Feb 2002
Location: Lake Michigan
My Boats: 353 Fastech
Posts: 6,624
Default

I was going to say "NOTHING GOT BROKE"....but i forgot that i ripped off my faring pad with a stuff.
Back4More is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:27 PM.


Copyright 2011 OffShoreOnly. All rights reserved.