Like Tree0Likes

It'Monday,Who brke what

Reply
Old 08-19-2002, 06:27 PM
  #1
Toxic FORMULA
Platinum Member
Thread Starter
 
mopower's Avatar
 
Join Date: May 2002
Location: pitman nj
My Boats: 1989 Formula SR-1 272 t/540's
Posts: 4,238
Default It'Monday,Who brke what

It's Monday and I was just wondering who broke what over the weekend.Isn't boating fun? How 'bout you Jayl13?
mopower is offline  
Reply With Quote
Old 08-19-2002, 06:38 PM
  #2
merlin540
Guest
 
Posts: n/a
Thumbs up

so far my new xz drive have lasted one weekend behind 970 hp how long do you think they will last lets post
 
Reply With Quote
Old 08-19-2002, 06:44 PM
  #3
Charter Member #415
Charter Member
 
Join Date: Nov 2000
Location: Jasper,Alabama
My Boats: 1968 Switzer Shooting Star,1967 Switzer Shooting Star,1963 Glasspar G-3
Posts: 3,357
Default

From Sat's Emerald Coast Poker Run in Ft Walton Beach,Fl I saw a Bravo XR blow on a new 38 Fountain with 575's,Another XR on a new MTI cat with with 575's,an XZ on a 353 Formula with 500's. May have been more. Merc is real good on covering warranty but seems like it would be cheaper on them to make a drive that will handle the stock power they sell them with than to continue to pay claims.
Magicfloat is offline  
Reply With Quote
Old 08-19-2002, 06:48 PM
  #4
Registered
 
Join Date: Apr 2002
Posts: 4,215
Default

I stayed home this past weekend because I have either broke or had somebody else break something on my boat (and trailer ) for the last 4 weekends I have been out
So, I am going to cross my fingers and try again this coming weekend
THRILLSEEKER is offline  
Reply With Quote
Old 08-19-2002, 07:01 PM
  #5
Registered
 
Pure Energy's Avatar
 
Join Date: Oct 2000
Location: N. NJ, Eastern LI
My Boats: 2001 Superboat Y2K
Posts: 3,027
Default

We got the boat running Sunday morning. Went out on the Hudson. 10 min ride, powered down, opened hatch for a peek and saw that alt. belt was very loose. Tried to tighten and found the bracket broke. So we cut the belt and continued. Got into some choppy water ran a little harder for some excitement and one motor lost all fuel pressure and stalled. Turned out to be loose grounds on the pump. Tightened them up and away we go. Another 5 min and both motors lost fuel pressure. Some how loosened back up. While tightening big wave came over the stern an splashed the motors. 1 motor fired the other did not. Pulled into a marina close by to try and find problem and discovered no spark, and after 1.5 hrs could not get one. Then we discover the drive pully on one of the prochargers is working itself off. Took the belt off(it was the motor that was running) and made the 3 hr. trip back to the ramp on 1 motor @ 10 mph.
Pure Energy is offline  
Reply With Quote
Old 08-19-2002, 07:02 PM
  #6
Registered
 
hot water's Avatar
 
Join Date: Feb 2002
Location: Northern California
My Boats: 2000 382 Formula Fastech
Posts: 480
Default

I was hoping the XR's would provide a more reliable drive but they do not seem to hold up any better than Bravo Ones.

My 1992 336 SR1 Formula had 600 hrs on stock Bravos with 170 of which bolted up to 530hp motors. My new 382 has 140hrs on Bravos pushing HP500 EFI's, no problems yet. I know I am just one of the lucky few and my days coming.

It seems that unless you are running number 6's you go out with your fingers crossed that your drives will get you home.
hot water is offline  
Reply With Quote
Old 08-19-2002, 07:25 PM
  #7
Member #9
Charter Member
 
hp500efi's Avatar
 
Join Date: Oct 2000
Location: Pewaukee, WI
Posts: 4,269
Default

Not boating related BUT I blew up my brand new Honda weed whacker

Went to tap the thing onto the ground to allow more string out and the whole spinner head went flying and now it is in the shop getting repaired.
__________________
Member of the Liquid Jungle
hp500efi is offline  
Reply With Quote
Old 08-19-2002, 08:01 PM
  #8
Registered
 
birdog's Avatar
 
Join Date: Jan 2002
Location: Batavia Oh.
My Boats: Top Gun
Posts: 4,034
Default

Rained all weekend........Didnt break a thing
birdog is offline  
Reply With Quote
Old 08-19-2002, 08:16 PM
  #9
Toxic FORMULA
Platinum Member
Thread Starter
 
mopower's Avatar
 
Join Date: May 2002
Location: pitman nj
My Boats: 1989 Formula SR-1 272 t/540's
Posts: 4,238
Default

I wish it would rain here So far this month we've only had a trace of rain. So let it rain Monday to Friday. Just be nice by next weekend.
mopower is offline  
Reply With Quote
Old 08-19-2002, 08:19 PM
  #10
Registered
 
traviss's Avatar
 
Join Date: Oct 2000
Location: On the river
My Boats: 1989 18.5 ft XLT powerplay
Posts: 3,372
Default

Well I put 7 hrs on mine over the weekend and nothing broke It was surprising cause it spent most of the time WFO

oh i did forget.. I had a ground wire under the dash come loose.. had to tighten that up and I changed the oil....

Last edited by traviss; 08-19-2002 at 10:29 PM.
traviss is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:50 PM.


Copyright 2011 OffShoreOnly. All rights reserved.