Go Back  Offshoreonly.com > Technical > General Q & A
power steering pump /hydraulic steering issue HELP >

power steering pump /hydraulic steering issue HELP

Like Tree2Likes

power steering pump /hydraulic steering issue HELP

Reply

Old 07-02-2019, 10:56 PM
  #1
Registered
Thread Starter
 
Join Date: Jun 2011
Posts: 300
Default power steering pump /hydraulic steering issue HELP

My old mere power steering pump was leaking so i was told the automotive ones are the same , I'm running full hydraulic steering but ever since I've installed this new pump my steering is super hard , I've done a little research and it says the automotive ones have a smaller diameter pressure release valve? aswell as a different spring ? can someone help me out here ive had this pump off more times then i can count , thinking about buying a marine one tomorrow if this will fix the issue , thanks
daniel475 is offline  
Reply With Quote
Old 07-03-2019, 07:07 AM
  #2
VIP Member
VIP Member
 
TomZ's Avatar
 
Join Date: Feb 2001
Location: Virginia Beach, VA
My Boat: '88 Formula 311 SR1 "Beach Party"
Posts: 1,819
Default

Assuming what you have is a standard GM pump.... take the spring/valve/orifice assembly from the old pump and put it in the new one. That should be all you need.
TomZ is offline  
Reply With Quote
Old 07-03-2019, 07:26 AM
  #3
Registered
Thread Starter
 
Join Date: Jun 2011
Posts: 300
Default

how do you identify the correct spring and valve , had two pumps on the shelf what I'm thinking happened is one of them got swapped with the incorrect spring and valve
daniel475 is offline  
Reply With Quote
Old 07-03-2019, 09:50 AM
  #4
Platinum Member
Platinum Member
iTrader: (1)
 
14 apache's Avatar
 
Join Date: Apr 2005
Location: Northport N.Y.
My Boat: Starchaser 87 Apache 41 Warpath
Posts: 2,068
Default

The spring should not make that much of a difference sounds like something is put together wrong of there is another problem. Did you change anything else? Is the filter clean?
14 apache is offline  
Reply With Quote
Old 07-03-2019, 10:11 AM
  #5
Registered
Thread Starter
 
Join Date: Jun 2011
Posts: 300
Default

I have not checked the filter but the system is brand new I could for sure check it , what im thinking is the relief valve and spring could be out of this automotive pump? but im not sure how to identify the proper relief valve and spring currently working on getting a marine pump if I can find one
daniel475 is offline  
Reply With Quote
Old 07-03-2019, 10:22 AM
  #6
Platinum Member
Platinum Member
iTrader: (1)
 
14 apache's Avatar
 
Join Date: Apr 2005
Location: Northport N.Y.
My Boat: Starchaser 87 Apache 41 Warpath
Posts: 2,068
Default

Is it a new helm too? Does it turn easy if you race the motor up?
14 apache is offline  
Reply With Quote
Old 07-03-2019, 10:25 AM
  #7
Registered
Thread Starter
 
Join Date: Jun 2011
Posts: 300
Default

system is brand new used only a few weekends from CP Performance , it feels like its kinda working just not fully , still fairly stiff , I haven't tried raising the motor up yet but ill try that but my guess it would be the same
daniel475 is offline  
Reply With Quote
Old 07-03-2019, 10:38 AM
  #8
Platinum Member
Platinum Member
iTrader: (5)
 
F-2 Speedy's Avatar
 
Join Date: May 2012
Location: Midwest & T-Rock
My Boat: F2 Speed racer
Posts: 6,145
Default

how did you bleed air from the system when you installed it, single ram, dual ram, single engine or 2....completely new system would take several quarts of fluid to fill
F-2 Speedy is offline  
Reply With Quote
Old 07-03-2019, 11:01 AM
  #9
Registered
Thread Starter
 
Join Date: Jun 2011
Posts: 300
Default

dual rams , single motor , yes it look a lot to initially prime it , the steering WAS working then my old merc power steering pump leaked so I thought I would replace it which I did , filled the new automotive one pretty much to the top obv could have been a little air in there , gonna try cracking rams at the back to see if there is any air ....
daniel475 is offline  
Reply With Quote
Old 07-03-2019, 11:37 AM
  #10
Registered
Thread Starter
 
Join Date: Jun 2011
Posts: 300
Default

https://www.cpperformance.com/p-2650...ring-pump.aspx , ordered one of these to at least bypass if it is a power steering pump issue
daniel475 is offline  
Reply With Quote

OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser