Go Back  Offshoreonly.com > Technical > General Q & A
Bravo Impeller Failure after 5 hours >

Bravo Impeller Failure after 5 hours

Notices

Bravo Impeller Failure after 5 hours

Old 10-24-2019, 04:51 PM
  #1  
Registered
Thread Starter
 
Join Date: Nov 2007
Location: Austin, Texas
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default Bravo Impeller Failure after 5 hours

New impeller in July (didnt replace housing just impeller) running down lake at 35 mph. Exhaust sound changed dramatically and temp started to go above 160 so knew something was up. Cut engine. Towed home. Remove seawater pump. Vanes on impeller look new, but shaft just spins inside of impeller. what could have caused this??
stinger222 is offline  
Old 10-24-2019, 05:01 PM
  #2  
Registered
 
Join Date: Jan 2005
Location: Katy, TX
Posts: 530
Likes: 0
Received 0 Likes on 0 Posts
Default

When you reinstalled, did you lay down the vanes the same way old one came out?
imartin is offline  
Old 10-24-2019, 05:03 PM
  #3  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 2,933
Received 95 Likes on 80 Posts
Default

From your comments, I need a bit more info

Can you post a pic?
AllDodge is offline  
Old 10-24-2019, 05:20 PM
  #4  
Registered
Thread Starter
 
Join Date: Nov 2007
Location: Austin, Texas
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default

Tried to post but got a BS note saying I cant post pics until Ive done 10 posts. Been on here for 10 years I guess I am have not been active enough. It looks like the impeller started to burn up from the inside out. Have never seen this happen, have always had vanes break off and burn up, never saw the inside get rounded out. Maybe the housing was messed up and caused the impeller to lock up the vanes. I did not install the vanes the same way as they came out on the new impeller, I thought I didnt matter that they flipped around to the correct orientation. I used car soap so the startup would be slick. worked fine for several boating outings until this past weekend.
stinger222 is offline  
Old 10-24-2019, 05:24 PM
  #5  
Registered
iTrader: (5)
 
Join Date: Jul 2009
Location: Taunton Ma
Posts: 7,848
Received 148 Likes on 79 Posts
Default

What brand impeller? Seen that a few times
Unlimited jd is online now  
Old 10-24-2019, 06:01 PM
  #6  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 2,933
Received 95 Likes on 80 Posts
Default

Ya got 10 post now, it should work
AllDodge is offline  
Old 10-24-2019, 06:05 PM
  #7  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 10,543
Received 256 Likes on 140 Posts
Default

Originally Posted by stinger222 View Post
New impeller in July (didnt replace housing just impeller) running down lake at 35 mph. Exhaust sound changed dramatically and temp started to go above 160 so knew something was up. Cut engine. Towed home. Remove seawater pump. Vanes on impeller look new, but shaft just spins inside of impeller. what could have caused this??
If the shaft spins but the impellar doesn't, see if the keyway is still there. The keyway is what holds the impeller in place on the pump shaft.
Or are you saying the the metal the rubber is bonded too spins also and the rubber unbonded from the metal tube in the impellar ?
SB is offline  
Old 10-24-2019, 06:27 PM
  #8  
Registered
iTrader: (5)
 
Join Date: Jul 2009
Location: Taunton Ma
Posts: 7,848
Received 148 Likes on 79 Posts
Default

I assumed bravo and the inner hub spun
Unlimited jd is online now  
Old 10-24-2019, 07:35 PM
  #9  
Registered
Thread Starter
 
Join Date: Nov 2007
Location: Austin, Texas
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by SB View Post
If the shaft spins but the impellar doesn't, see if the keyway is still there. The keyway is what holds the impeller in place on the pump shaft.
Or are you saying the the metal the rubber is bonded too spins also and the rubber unbonded from the metal tube in the impellar ?
Looks like the keyway inside is rounded out/stripped
stinger222 is offline  
Old 10-24-2019, 07:43 PM
  #10  
Registered
iTrader: (5)
 
Join Date: Jul 2009
Location: Taunton Ma
Posts: 7,848
Received 148 Likes on 79 Posts
Default

On a bravo? There is no key way,
Unlimited jd is online now  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.