Go Back  Offshoreonly.com > Technical > General Q & A
Arizona Speed & Marine EFI's >

Arizona Speed & Marine EFI's

Like Tree14Likes

Arizona Speed & Marine EFI's

Old 11-13-2019, 11:30 AM
  #1  
Platinum Member
Platinum Member
Thread Starter
iTrader: (3)
 
scippy's Avatar
 
Join Date: Jan 2007
Location: Jackson, n.j. ~ Brooklyn, n.y.
Posts: 1,720
Default Arizona Speed & Marine EFI's

Can someone tell me how you can adjust the idle speed (rpm's) on a AS&M EFI?....the port engine idle speed on my 575 is a high 2,000 rpm's while the other is just barely choking out.
scippy is offline  
Old 11-13-2019, 01:40 PM
  #2  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 10,063
Default

You'll have to check with them for specs. Most likely it's a stuck IAC or really big vacuum leak. Do these have PCV valves by any chance ?

Also, disconnect throttle cable to make sure that or t-body itself is not binding.
SB is offline  
Old 11-13-2019, 02:35 PM
  #3  
Platinum Member
Platinum Member
Thread Starter
iTrader: (3)
 
scippy's Avatar
 
Join Date: Jan 2007
Location: Jackson, n.j. ~ Brooklyn, n.y.
Posts: 1,720
Default

Originally Posted by SB View Post
You'll have to check with them for specs. Most likely it's a stuck IAC or really big vacuum leak. Do these have PCV valves by any chance ?

Also, disconnect throttle cable to make sure that or t-body itself is not binding.
SB Good advice Thanks!....don't know if they have PCV valves....but will contact AS&M ......not as easy as a carburetor-ed system.
scippy is offline  
Old 11-14-2019, 02:04 PM
  #4  
Platinum Member
Platinum Member
Thread Starter
iTrader: (3)
 
scippy's Avatar
 
Join Date: Jan 2007
Location: Jackson, n.j. ~ Brooklyn, n.y.
Posts: 1,720
Default

Called AS&M ....there is no PCV valve, but recommend a scan tool to read the computer and set the right parameters ....trouble is Scan tool costs $550.....before I invest, would there be another way?
scippy is offline  
Old 11-14-2019, 02:17 PM
  #5  
Registered
 
Join Date: Apr 2013
Location: Lake Winnebago
Posts: 195
Default

Likely a MEFI ECM...check out this site (OBD Diagnostics). Options for tuning and scanning using your laptop.

Scan only software here --> OBD Diagnostics

Last edited by SS496; 11-14-2019 at 02:21 PM.
SS496 is offline  
Old 11-14-2019, 03:13 PM
  #6  
Platinum Member
Platinum Member
Thread Starter
iTrader: (3)
 
scippy's Avatar
 
Join Date: Jan 2007
Location: Jackson, n.j. ~ Brooklyn, n.y.
Posts: 1,720
Default

SS496.....AS&M suugests this scan tool used through my laptop https://www.rinda.com/rindashop/shop...acom-94105-kit now here's my question, is it only Arizona Speed & Marine
that hold the right calibrations to get my efi's running correctly?.........My engines are Flagship built in '96 (I have the dyno sheet) I believe I have 10 pin connector ....can I get close without
getting a printout from AS&M?........I'm confused!
scippy is offline  
Old 11-14-2019, 03:41 PM
  #7  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 10,063
Default

Diagnostic software is not programming software.

I'm afraid to ask - no I am not ! and Epstein did not kill him self ! do you know how to read / decipher ECU/engine data ?
SB is offline  
Old 11-14-2019, 06:23 PM
  #8  
Platinum Member
Platinum Member
Thread Starter
iTrader: (3)
 
scippy's Avatar
 
Join Date: Jan 2007
Location: Jackson, n.j. ~ Brooklyn, n.y.
Posts: 1,720
Default

Originally Posted by SB View Post
Diagnostic software is not programming software.

I'm afraid to ask - no I am not ! and Epstein did not kill him self ! do you know how to read / decipher ECU/engine data ?
I don't mind your attempt at sarcasm, but forgive me if i'm missing a very subtle funny moment here and no, I don't read/ decipher ECU/ engine data.
scippy is offline  
Old 11-14-2019, 06:42 PM
  #9  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 2,288
Default

Forget AS&M, its a MEFI 1 ECM and has very little parameters which can be used to determine issue. Knowing the IAC count and MAP would help, but like SB I think you have a vacuum leak or stuck IAC.

For others looking I would suggest using the 500 EFI listing for parts
The IAC is item 34
https://www.mercruiserparts.com/bam/...31336/7595/130

And you may very well have a PVC valve item 7

Find a port/line which a vacuum gauge can be connected
articfriends likes this.
AllDodge is offline  
Old 11-14-2019, 08:04 PM
  #10  
Platinum Member
Platinum Member
iTrader: (6)
 
F-2 Speedy's Avatar
 
Join Date: May 2012
Location: Midwest & T-Rock
Posts: 6,528
Default

looks to be a 500 efi intake and plenum, pcv valve sits in the middle of the lower intake and connects by hose to the upper plenum, Id be supprised if it wasnt password protected if ASM has a custom tune in it

Last edited by F-2 Speedy; 11-14-2019 at 08:11 PM.
F-2 Speedy is offline  

OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser