Go Back  Offshoreonly.com > Technical > General Q & A
Engine upgrade advice - 500HP / 525EFI >

Engine upgrade advice - 500HP / 525EFI

Notices

Engine upgrade advice - 500HP / 525EFI

Old 11-22-2020, 04:09 PM
  #41  
Registered
Thread Starter
 
Join Date: Sep 2019
Location: Sweden
Posts: 273
Received 15 Likes on 11 Posts
Default

Nothing yet. Still have my 496 for sale
JohanSweden is offline  
Old 11-22-2020, 04:44 PM
  #42  
Registered
 
Join Date: Mar 2020
Location: Central Louisiana
Posts: 885
Received 581 Likes on 295 Posts
Default

Originally Posted by JohanSweden
No more than lack of power what I know.
I have self thought about this. But many people have adviced me against it. Because supercharge a CBB Gen VII 496 is begging for problems, but thats just what I heard. I have no experience of it.
Theres so little price difference from my 496 to the 540 Bulldog. The money I spend on parts for the 496 is more than what I put extra money for the 540 .
After I posted this I did a little reading on it. Lots of mixed reviews about supercharging the 496. I see a lot of boats for sale with them but they all have low hours due to rebuilds or "freshening up". I definitely think you are on the right track. For some reason I really like the 525's but Ive never owned one. They seem to be a very solid reliable engine. If I ever upgrade boats I would like to have one or two.
Eddienel is offline  
Old 11-24-2020, 03:32 PM
  #43  
Registered
Thread Starter
 
Join Date: Sep 2019
Location: Sweden
Posts: 273
Received 15 Likes on 11 Posts
Default

Originally Posted by Eddienel
After I posted this I did a little reading on it. Lots of mixed reviews about supercharging the 496. I see a lot of boats for sale with them but they all have low hours due to rebuilds or "freshening up". I definitely think you are on the right track. For some reason I really like the 525's but Ive never owned one. They seem to be a very solid reliable engine. If I ever upgrade boats I would like to have one or two.
Yes there is. And thats worring me too much to supercharge my 496. Better sell it and buy a solid engine.

Just currious about the livorsi gauges. It is Smartcraft today with the 496. The 540 Bulldog doesnt have Smartcraft, do I have to replace my gauges with other or can I connect them to the Merc 540 in some way?
JohanSweden is offline  
Old 11-25-2020, 02:25 AM
  #44  
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha/LOTO
Posts: 19,483
Received 1,739 Likes on 859 Posts
Default

Originally Posted by JohanSweden
Yes there is. And thats worring me too much to supercharge my 496. Better sell it and buy a solid engine.

Just currious about the livorsi gauges. It is Smartcraft today with the 496. The 540 Bulldog doesnt have Smartcraft, do I have to replace my gauges with other or can I connect them to the Merc 540 in some way?
If you are running smartcraft and regular Livorsi analog gauges, then you must be running an AGI box ?? https://www.mercruiserparts.com/anal...igital-engines
Just bypass the AGI box
Griff is offline  
Old 11-25-2020, 10:02 AM
  #45  
Registered
Thread Starter
 
Join Date: Sep 2019
Location: Sweden
Posts: 273
Received 15 Likes on 11 Posts
Default

Originally Posted by Griff
If you are running smartcraft and regular Livorsi analog gauges, then you must be running an AGI box ?? https://www.mercruiserparts.com/anal...igital-engines
Just bypass the AGI box
I am running the vantage view gauges:
West Coast Offshore: Livorsi Marine Vantage View Gauges

Where are this AGI box located?
JohanSweden is offline  
Old 12-27-2020, 05:26 PM
  #46  
Registered
 
Join Date: Dec 2020
Posts: 1
Received 0 Likes on 0 Posts
Default

Frankcjr you not getting everything out of your 496 I believe you said 425 horsepower that would be a mag ho that boat should do 65 to 70 stock at 5100 rpm sounds like you got the wrong prop my stock 496 mag ho came with a 23 p mirage 3 blade got 68 to 70 added supercharger 5lb running 26p 4 blade bravo 1 prop at 5200 rpm doing 78 just my thoughts
Frankcjr is offline  
Old 12-28-2020, 01:26 AM
  #47  
Registered
Thread Starter
 
Join Date: Sep 2019
Location: Sweden
Posts: 273
Received 15 Likes on 11 Posts
Default

Originally Posted by Frankcjr
Frankcjr you not getting everything out of your 496 I believe you said 425 horsepower that would be a mag ho that boat should do 65 to 70 stock at 5100 rpm sounds like you got the wrong prop my stock 496 mag ho came with a 23 p mirage 3 blade got 68 to 70 added supercharger 5lb running 26p 4 blade bravo 1 prop at 5200 rpm doing 78 just my thoughts
This summer I tested a 24P Bravo prop.
(The bravo is overrated so more likely a 23,3P)
It run 59 mph @4750 rpm.
I find out my gear ratio is 1.5:1 after I counted the gear tooths.

So you say that my engine isnt using its full power? I think I have some issues with one cylinder missfiring or something. But I dont know if its the whole time or just happens between 800-1500 rpm.

Look at my other thread ”Mercruiser 496 problem”.
JohanSweden is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.