Go Back  Offshoreonly.com > Technical > Restorations & Upgrades
Mirage 217 -Bringing it back >

Mirage 217 -Bringing it back

Notices

Mirage 217 -Bringing it back

Old 10-19-2020, 11:12 AM
  #11  
Registered
Thread Starter
 
Join Date: Sep 2020
Posts: 12
Received 0 Likes on 0 Posts
Default

Originally Posted by 87MirageIntruder View Post
I towed my Mirage 217 no problem with half ton trucks over the years. I had a '04 Titan, '09 Ram Hemi, and a '16 Ram Hemi. My Mirage had a Calkins galvanized tandem axle under it. Towed really nice.

In '18 when I sold the Mirage and got a Nordic 28 Heat with a tri axle, the '16 Ram Hemi towed that no problem either, I just put air bags in the rear springs. (Now I use a 2500 Cummins to tow it)
I was actually pretty surprised, but googling "f150 tow sway" confirms I am not the only one with this issue. Like you, I had a custom galvanised trailer made for it and set up by the manufacturer and have towed at super-highway speeds without issues, the last vehicle being a '98 Durango. It lacked power but no other issues.

Anyway I am pretty hopeful the upgrades will help.
DougB is offline  
Old 10-19-2020, 06:56 PM
  #12  
Registered
Thread Starter
 
Join Date: Sep 2020
Posts: 12
Received 0 Likes on 0 Posts
Default

Anyway onto the boat. Got a call from the mechanic, the electric fuel pump is NFG, so will be ordering a new one. Hopefully that's the main culprit.The mercruiser one is apparently available so should know later this week if things go well.
DougB is offline  
Old 10-28-2020, 08:40 PM
  #13  
Registered
Thread Starter
 
Join Date: Sep 2020
Posts: 12
Received 0 Likes on 0 Posts
Default

Well the fuel pump arrived
He kinda got the engine running, but it won't idle, so more checking is in order.
Along with a few other recommended things, he is starting with checking the injectors to see if there is an issue with one or two.
Probably be a few more days before I know more
DougB is offline  
Old 11-22-2020, 01:25 PM
  #14  
Registered
Thread Starter
 
Join Date: Sep 2020
Posts: 12
Received 0 Likes on 0 Posts
Default

I had a call from the engine guy (while in the midst of setting up xmas lights) that he got all the parts last week and installed it all. Says he has it all running really nice, idling nice, no error codes. But wants me to take it out and run it up to full throttle (as opposed to the garden hose connection) to see how everything else is.

I just have to find a decent winter day and dress warm now
DougB is offline  
Old 11-22-2020, 01:28 PM
  #15  
Registered
Thread Starter
 
Join Date: Sep 2020
Posts: 12
Received 0 Likes on 0 Posts
Default

Looks like I can add pics now


After gelcoat restoration and awaiting the swim platform
DougB is offline  
Old 04-15-2021, 07:33 PM
  #16  
Registered
Thread Starter
 
Join Date: Sep 2020
Posts: 12
Received 0 Likes on 0 Posts
Default

It's been a bit of a wait for the more spring like weather here, but it finally arrived so it was time to start her up.
As promised my engine guy did a nice job. It fired up instantly and sounds good at idle.
Hoping to get some more good weather and do some in-water testing soon.

https://photos.app.goo.gl/XMqpMFSYH2wgJFRQ9

DougB is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.