Like Tree0Likes

Prop Spin??

Reply
Old 05-31-2007, 05:47 PM
  #1
Gold Member
Gold Member
Thread Starter
 
Join Date: Feb 2006
Location: Cicero, NY
My Boats: Wellcraft Excalibur 26
Posts: 162
Default Prop Spin??

Prop Spin or what??

I have a 2001 Wellcraft Excalibur 26ft 496 built motor Dyno shows 570 HP. It runs great on plane running at high speeds, at cruzing speeds in choppy water I have allot of RPM movement. Basically if Im running just on plane 2600 to maybe 2900 RPM range. The RPMS jump up and down buy about 500 Rs or so. It is almost like they go up and down as I go over the waves. If its calm out this never happens. Just wonder if that was somewhat common. My old boat the Rs never change regardless of conditions unless you moved the throttle. Im running a 24 P Bravo1 prop - Is this normal or ok at least?
JBoat is offline  
Reply With Quote
Old 05-31-2007, 08:47 PM
  #2
Pirate of the Chesapeake
Gold Member
Trade Score: (2)
 
Fenderjack's Avatar
 
Join Date: Aug 2006
Location: North Point Creek, Md.
Posts: 4,330
Default

I would have to think that it is because the prop is slipping or cavitating just a bit when in the choppy water. What was your previous boat, the wellcraft X probably has a higher X dem so the drive is already closer to the surface, then your old boat..
Fenderjack is offline  
Reply With Quote
Old 06-01-2007, 06:17 PM
  #3
Gold Member
Gold Member
Thread Starter
 
Join Date: Feb 2006
Location: Cicero, NY
My Boats: Wellcraft Excalibur 26
Posts: 162
Default

Possibly - the old boat was a wellcraft eclipse. more of a run about. I just have never seen any boat have the rpm range move so drastically. Should I be considering a diffrent prop ? I can deal with the up and down but I cant think its great for the motor.
JBoat is offline  
Reply With Quote
Old 06-07-2007, 07:10 PM
  #4
Gold Member
Gold Member
Thread Starter
 
Join Date: Feb 2006
Location: Cicero, NY
My Boats: Wellcraft Excalibur 26
Posts: 162
Default

any more input boys . i want to make sure im not soing any damage running her like this. All else seem to be up to par.
JBoat is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sierraspringsjay
General Q & A
3
05-27-2008 05:20 PM
tgersx
General Q & A
8
05-30-2007 03:08 PM
tgersx
Drives and Lower Units
1
05-29-2007 09:32 PM
BillR
General Q & A
16
09-15-2002 07:26 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:02 PM.


Copyright 2011 OffShoreOnly. All rights reserved.