Like Tree1Likes

GPS speedo question

Reply
Old 04-27-2009, 08:17 AM
  #1
Registered
Thread Starter
 
SeaDated's Avatar
 
Join Date: Mar 2001
Location: Kennesaw, GA, USA
My Boats: 2004 38 Fountain Lightning
Posts: 853
Default GPS speedo question

I have a Livorsi GPS speedo that reads 30MPH no matter what speed I am running. The tattle tale works and the gauge does it's normal route at start up (meaning the needle swings full scale then back to zero) However if only stays at zero for a few seconds then goes to 30. Any help? Is it a bad gauge or antenna?
SeaDated is offline  
Reply With Quote
Old 04-27-2009, 08:23 AM
  #2
Registered
 
gsmith9898's Avatar
 
Join Date: Mar 2005
Location: tulsa, oklahoma
Posts: 1,870
Default

You have to send it in for a new battery. $75
gsmith9898 is offline  
Reply With Quote
Old 04-27-2009, 08:26 AM
  #3
Registered
Trade Score: (1)
 
29KILROY's Avatar
 
Join Date: Mar 2004
Location: LOCKPORT, N.Y.
My Boats: -272, Killer 29 Outlaw, Boatless- For Now....
Posts: 689
Default

I had the same thing happen it was the Antenna. They fixed it for Free! Livorsi was AEWSOME to deal with!!!!
29KILROY is offline  
Reply With Quote
Old 04-27-2009, 08:47 AM
  #4
Registered
Thread Starter
 
SeaDated's Avatar
 
Join Date: Mar 2001
Location: Kennesaw, GA, USA
My Boats: 2004 38 Fountain Lightning
Posts: 853
Default

29KILROY Thanks I'll give them a call.

gsmith Battery, what battery?
SeaDated is offline  
Reply With Quote
Old 04-27-2009, 10:33 AM
  #5
Platinum Member
Platinum Member
 
BDiggity's Avatar
 
Join Date: Feb 2005
Location: OP/LOTO
My Boats: 91 Cig Cafe
Posts: 1,619
Default

Quote:
Originally Posted by SeaDated View Post
29KILROY Thanks I'll give them a call.

gsmith Battery, what battery?

antenna battery. there was a thread somewhere that its pretty easy to yourself for like the cost of the battery which is a couple bucks.
BDiggity is offline  
Reply With Quote
Old 04-27-2009, 10:43 AM
  #6
Registered
Thread Starter
 
SeaDated's Avatar
 
Join Date: Mar 2001
Location: Kennesaw, GA, USA
My Boats: 2004 38 Fountain Lightning
Posts: 853
Default

BDiggity

I'll do a search and see what comes up. I did call and they send to send them the antenna so I bet you guys hit it dead on the money
SeaDated is offline  
Reply With Quote
Old 04-27-2009, 10:54 AM
  #7
VIP Member
VIP Member
 
BraceYourself's Avatar
 
Join Date: Feb 2006
Location: Oh
Posts: 1,030
Default

Just sent mine in.

They charged my card $91.10

It fixed the problem, but what a dumb ass setup. You'd think there would be a better way to make it rather then a battery that goes bad every few years.

Last edited by BraceYourself; 04-27-2009 at 10:56 AM.
BraceYourself is offline  
Reply With Quote
Old 04-27-2009, 10:54 AM
  #8
Registered
 
Join Date: Jun 2007
Location: Denham Springs La.
My Boats: 2008 26' Revolution Performance Marine
Posts: 606
Default

Quote:
Originally Posted by BDiggity View Post
antenna battery. there was a thread somewhere that its pretty easy to yourself for like the cost of the battery which is a couple bucks.
Never heared that one, send it to Livorci, they are great to deal with, also check your ant. connections and ground to spedo...could just need to be cleaned and tightind again.
26 REDLINE is offline  
Reply With Quote
Old 04-27-2009, 11:59 AM
  #9
Registered
 
JasonSmith's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,333
Default

Quote:
Originally Posted by 26 REDLINE View Post
Never heared that one, send it to Livorci, they are great to deal with, also check your ant. connections and ground to spedo...could just need to be cleaned and tightind again.
Yup, the antenna has a battery in it. Pretty dumb a$$ way to make it work, but I guess it works.
JasonSmith is offline  
Reply With Quote
Old 04-27-2009, 10:03 PM
  #10
Platinum Member
Platinum Member
 
HUSTLEthis's Avatar
 
Join Date: Nov 2001
Location: Laguna Beach,Ca.
Posts: 793
Default

We had the same problem...didn't know there was a battery issue though...
sent it in and they fixed it...75 bucks to us....
HUSTLEthis is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:42 AM.


Copyright 2011 OffShoreOnly. All rights reserved.