Go Back  Offshoreonly.com > Technical > General Q & A
525 efi issue >

525 efi issue

Like Tree9Likes

525 efi issue

Reply

Old 06-23-2018, 07:08 AM
  #1
Registered
Thread Starter
 
Join Date: Jun 2018
Location: Lake St Clair, Mi
My Boat: 382 Formula Fastech
Posts: 8
Angry 525 efi issue

Hello everybody, first time on the OSO Forum. I have a 2005 382 Formula Fastech w/ 525 EFI's, 350 hrs. My problem is the port motor. When it goes above 3100-3200 rpm the alarm will beep very quickly. So for example if I bring it up to 4000 rpm, the alarm will sound, rpm drops to 3100 ish for a second and then goes right back up to the 4000 rpm . This will continue back and forth every 5 seconds or so at all rpm's above the 3100 mark. Any ideas???? it is a Smart Craft motor but I do NOT have the Smart Craft Display.
RaceBoat42 is offline  
Reply With Quote
Old 06-23-2018, 07:13 AM
  #2
VIP Member
VIP Member
 
VoodooRob's Avatar
 
Join Date: Jul 2011
Location: Cleveland Ohio
My Boat: 07 38 Lightning 600SCIs
Posts: 1,703
Default

Shot in the dark, how is your water pressure? 525s like new impellers and impeller housing every season. If you own 525s a Rinda scan tool is one of your best investments. Plug it in and you can see every code, alarm, and running conditions. Avoid aggravation and frustration and save $ from guessing the fix to a problem, just some friendly advice. Im speaking from experience, same engines in our last boat.
I also had sensors go bad three times on my 525s ruining my weekends, if I had a scan tool earlier in ownership time I would have been able to diagnose and get it fixed fast.
SB likes this.

Last edited by VoodooRob; 06-23-2018 at 07:16 AM.
VoodooRob is offline  
Reply With Quote
Old 06-23-2018, 07:22 AM
  #3
Registered
Thread Starter
 
Join Date: Jun 2018
Location: Lake St Clair, Mi
My Boat: 382 Formula Fastech
Posts: 8
Default

Thanks, I am definitely going to check into the Rinda scan tool on Monday. Just trying to figure out the problem ASAP due to the fact I have a poker run on Wednesday. Yes, replaced both sea pumps last month.
RaceBoat42 is offline  
Reply With Quote
Old 06-23-2018, 07:37 AM
  #4
Registered
iTrader: (3)
 
Join Date: Apr 2005
Location: Lees Summit ~ LOTO 10MM
My Boat: 43SC ...............Black Thunder
Posts: 2,719
Default

Similar issue. I’m on the way to the shop to plug the boat in. I’ll update with my findings, hopefully that will help you out. Also, if you search it out, there is a schematic in what beeps mean what (very generic). As mentioned above, the scan tool is very much needed.
endeavor1 is offline  
Reply With Quote
Old 06-23-2018, 07:53 AM
  #5
Registered
Thread Starter
 
Join Date: Jun 2018
Location: Lake St Clair, Mi
My Boat: 382 Formula Fastech
Posts: 8
Default

Thanks, well appreciated. I came across a thread that suggested the neutral safety switch? Your thoughts?
RaceBoat42 is offline  
Reply With Quote
Old 06-23-2018, 07:58 AM
  #6
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 9,184
Default

Setting yourself up to throw darts.

You are in a very large boat area....I would get on the phone and see if anyone will run the code for you.

Also, do a post in the mich section to see if anyone near you that has a scanner.
SB is offline  
Reply With Quote
Old 06-23-2018, 08:17 AM
  #7
Registered
Thread Starter
 
Join Date: Jun 2018
Location: Lake St Clair, Mi
My Boat: 382 Formula Fastech
Posts: 8
Default

I've tried all of the local boat shops, all telling me a week out or so..... I will try the local post. Thanks.
RaceBoat42 is offline  
Reply With Quote
Old 06-23-2018, 08:20 AM
  #8
Registered
 
Join Date: Jun 2005
Location: Johns Creek, GA
My Boat: 2000 Baja 252 Islander- 2003 Eliminator 30 Daytona
Posts: 74
Default

Mine was similar and turned out to be the neutral safety switch but my mechanic pointed out that several faults will result in the computer limiting the engine to 3000 rpm’s so only a scan tool will be able to determine which one.
Adding the mobile vessel view plugin this year so I can see what is going on and hopefully avoid future guessing.
SB and VoodooRob like this.
papps is offline  
Reply With Quote
Old 06-23-2018, 10:26 AM
  #9
Registered
Thread Starter
 
Join Date: Jun 2018
Location: Lake St Clair, Mi
My Boat: 382 Formula Fastech
Posts: 8
Default

Problem solved. It was the neutral safety switch. Thanks for the help guys.
SB, thirdchildhood and VoodooRob like this.
RaceBoat42 is offline  
Reply With Quote
Old 06-23-2018, 10:56 AM
  #10
BUP
Registered
iTrader: (7)
 
Join Date: Jul 2011
Location: Ft. Worth TX
Posts: 7,593
Default

Just to be clear - are we talking the shift in gear switch or the neutral safety switch ? the reason I ask because so many people call the shift in gear switch the neutral safety. switch. They are 2 completely different switches.
BUP is offline  
Reply With Quote

OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser