Like Tree0Likes

carbs.. carbs and more carbs..

Reply
Old 05-16-2008, 05:18 PM
  #11
Registered
Thread Starter
 
Join Date: Oct 2007
Posts: 22
Default

Thank you all for your replies..
At first I think my accelerator pump was not working right as it was not pumping very much until the boat ran for 3-4 days here and there.. I was pumping the gas at the carb and seeing very little fuel coming from the jets.. now there is lots...I think it is getting to much...
What can I do to fix that??
The carb is not very old..Edlebrock ( which is really what a quadrajet in disquise...!!)
if I ease into it the engine runs fine..
YOLO is offline  
Reply With Quote
Old 05-16-2008, 09:51 PM
  #12
Gold Member
Gold Member
Trade Score: (2)
 
spazboz's Avatar
 
Join Date: Dec 2006
Location: Zeeland, Michigan
My Boats: 26' Wellcraft Nova II, Wellcraft 210 Elite, PowerPlay 185 XLT
Posts: 1,150
Default

Time to rebuild the carb. As mentioned before, don't forget to replace your fuel/water separator also.
spazboz is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
AS IS
General Q & A
15
03-30-2011 12:30 PM
randy carlson
Wanted
3
03-14-2008 04:08 PM
sneekinfreek
General Q & A
7
03-18-2007 02:58 PM
LubeJobs42
General Boating Discussion
3
03-10-2005 11:36 PM
Donzi Black Widow
General Q & A
12
11-02-2004 01:02 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:09 AM.


Copyright 2011 OffShoreOnly. All rights reserved.